Download it now!
Bug 130658 - Crash on adding word to User-defined dictionary (gtk3)
Summary: Crash on adding word to User-defined dictionary (gtk3)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0 target:6.4.1 target:6.3.6
Keywords: bibisected, bisected, regression
: 130694 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-02-14 12:26 UTC by Brian
Modified: 2020-03-06 12:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian 2020-02-14 12:26:12 UTC
Description:
I wanted to suppress the auto-hyphenation of a single word in a document via these instructions https://help.libreoffice.org/6.1/en-US/text/swriter/guide/hyphen_prevent.html?DbPAR=WRITER 

Steps to Reproduce:
1. https://help.libreoffice.org/6.1/en-US/text/swriter/guide/hyphen_prevent.html?DbPAR=WRITER
2. Name: Prevent Hyphens
3. Language: [ALL]
4. Exception (-): unchecked
6. Select the new dictionary and click 'Edit'
7. Enter a new word and click 'New'

Actual Results:
Crash occurs when clicking the 'New' button.
Dialog box and main 'Options' dialog boxes still open and can not be closed, 'Recovery' dialog box immediately opens in the background. Clicking through it closes the other dialogs and returns things to normal.

Expected Results:
Successful addition to the dictionary, that added word is no longer auto-hyphened even when that option is enable for everything else.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
When I first created the dictionary there was no problem and it was initially unchecked, this happen when I try to edit it.

Workaround: Changing the dictionary type to [English (USA)] works correctly, auto-hyphenation of that single word is disabled. Attempting to add a word to "List of Ignored Words [All]" or "standard [All]" results in the same crash. Other dictionaries like "en-GB [English (UK)]", "en-US [English (USA)]", "technical [All]" could not be edited but did not trigger a crash.

LibreOffice (a previous version) came per-installed with Ubuntu through the Snap Store. My guess is some kind or permission problem. I use everything under my standard user account. I am the owner of /home/USERNAME/snap/libreoffice I'm also the owner of /home/USERNAME/snap/libreoffice/170/.config/libreoffice/4/user/wordbook/Prevent Hyphens.dic but my group and everyone only has read access. Opening LibreOffice from the favorites side-bar and saving a blank document always defaults to /home/USERNAME/snap/libreoffice/170 instead of my home directory.

Possibly related to 68576

Build ID: libreoffice-6.4.0.3-snap1

"Tools ▸ Options ▸ LibreOffice ▸ View ▸ Use OpenGL for all rendering" does not exist, should this be "Use hardware acceleration" or "Tools ▸ Options ▸ LibreOffice ▸ OpenCL ▸ Allow use of OpenCL"?
Comment 1 Xisco Faulí 2020-02-14 13:08:28 UTC
I can't reproduce it in

Version: 7.0.0.0.alpha0+
Build ID: f4b6f6a8ae60bdec53512728d00853b73fa18500
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 2 Xisco Faulí 2020-02-14 13:09:47 UTC
but I do in

Version: 7.0.0.0.alpha0+
Build ID: f4b6f6a8ae60bdec53512728d00853b73fa18500
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

thus, GTK3 only
Comment 3 Xisco Faulí 2020-02-14 13:33:23 UTC
For me, LibreOffice started to crash after

author	Caolán McNamara <caolanm@redhat.com>	2019-11-20 10:05:48 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-11-20 13:41:32 +0100
commit	19116d1061b287eef600ec6b3f46c362a4abd405 (patch)
tree	8fe747c4b27aa9156163adaba410eaa635712a6c
parent	eee6ef53ebc5756a974e985925550dcd990876ca (diff)
consistency wrt notification events for treeview cursor change

Bisected with: bibisect-linux64-6.5$

Adding Cc: to Caolán McNamara

Before that, LibreOffice hangs adding a word. Bisecting next
Comment 4 Xisco Faulí 2020-02-14 14:05:13 UTC
The hang was introduced by:

author	Caolán McNamara <caolanm@redhat.com>	2019-02-18 12:11:08 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-02-19 22:18:10 +0100
commit	12a59a1f2948274c6a845ab4a0963bab8aff45b8 (patch)
tree	d7877f8e78aad8b53df428773947228e88a151f3
parent	e9bc6efbb8f1c1d012e60f3fc9877d311a48ee03 (diff)
weld ChineseDictionaryDialog

Bisected with: bibisect-linux64-6.3
Comment 5 Commit Notification 2020-02-14 16:52:02 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2339b36033695f2b79997702770698f5db3ec4af

Resolves: tdf#130658 there isn't a second column in non-exception mode

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2020-02-15 10:42:15 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: aa58c380894dd384f6ce1efc62b3932136f2f477
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!
Comment 7 Commit Notification 2020-02-15 10:43:37 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/069895a8961b474961b287e3139e4c4c042ad845

Resolves: tdf#130658 there isn't a second column in non-exception mode

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-02-19 13:40:29 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-1":

https://git.libreoffice.org/core/commit/95ab6b531941bc8e1527ccfe8e5ccfc61922f5b9

Resolves: tdf#130658 there isn't a second column in non-exception mode

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2020-02-25 08:30:34 UTC
Closing as VERIFIED FIXED
Comment 10 Commit Notification 2020-02-25 08:36:23 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/91e8ee86d499b759aa6639368a40528482e49fb6

Resolves: tdf#130658 there isn't a second column in non-exception mode

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Brian 2020-03-05 11:41:06 UTC
Verified fixed in Version: 6.4.2.1 Build ID: c92dba0b4728c0ec26c4b83e2c0fbf3284425375

Thanks Caolán.
Comment 12 Xisco Faulí 2020-03-06 12:11:39 UTC
*** Bug 130694 has been marked as a duplicate of this bug. ***