Download it now!
Bug 130749 - Shift F3 capitalization causes non-selected text to lose its capitalization.
Summary: Shift F3 capitalization causes non-selected text to lose its capitalization.
Status: RESOLVED DUPLICATE of bug 49033
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.8.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Character Selection
  Show dependency treegraph
 
Reported: 2020-02-18 02:53 UTC by Galen Currah
Modified: 2020-02-21 08:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Galen Currah 2020-02-18 02:53:30 UTC
Description:
When we select text, then press Shif+F3 to modify that text's capitalization, non-selected text in the same document change its capitalization in non-predictable ways. 

Steps to Reproduce:
1. Begin with a document that has capitalized words.
2. Select other text and press Shift+F3.
3. Observe the words in step 1.

Actual Results:
Capitalization of non-selected text changes non-predictably.

Expected Results:
Only the selected text should change its capitalization (upper or lower case).


Reproducible: Always


User Profile Reset: No



Additional Info:
We love LibreOffice and employ it almost every day.
Comment 1 Ahmad Haris 2020-02-18 10:44:36 UTC
Is that Shift + F3 is cycle case? which is will rotate UPPERCASE, lowercase, Sentence case, Capitalize Every Word and tOGGLE cASE?
Comment 2 Dieter 2020-02-21 08:10:49 UTC
Galen, thank you for reporting the bug. It looks like a duplicate of bug 49033, so I mark it as RESOLVED DUPLICATE.Please feel free to change it back to UNCONFIRMED with a short reasoning, if you disagree.

*** This bug has been marked as a duplicate of bug 49033 ***