Download it now!
Bug 130766 - Assertion failure when undoing editing in attached document
Summary: Assertion failure when undoing editing in attached document
Status: RESOLVED DUPLICATE of bug 131147
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: Track-Changes Crash-Assert Undo-Redo
  Show dependency treegraph
 
Reported: 2020-02-19 03:58 UTC by Aron Budea
Modified: 2020-04-06 12:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample ODT (10.03 KB, application/vnd.oasis.opendocument.text)
2020-02-19 03:58 UTC, Aron Budea
Details
Backtrace (22.53 KB, text/plain)
2020-02-19 03:59 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2020-02-19 03:58:13 UTC
Created attachment 157993 [details]
Sample ODT

This is an assertion failure, and requires a debug build to repro.

- Open attached ODT.
- Select the first character, and type a character.
- Undo.

=> Assertion failure.

Assertion seems to be related to change tracking.

Observed using LO 7.0.0.0.alpha0+ (cbfa11ab8f429bf0cb279c732ec7a8dba0090104) / Ubuntu.
Comment 1 Aron Budea 2020-02-19 03:59:36 UTC
Created attachment 157994 [details]
Backtrace
Comment 2 NISZ LibreOffice Team 2020-04-06 12:05:15 UTC
#2  0x00007ffff7a6c769 in __assert_fail_base (fmt=0x7ffff7c00fb8 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=0x7fffc9194e90 "rSData.empty() || (rSData[0].nRedlineCount == rDoc.getIDocumentRedlineAccess().GetRedlineTable().size())", file=0x7fffc91931a8 "/home/valaki/projects/libreoffice/sw/source/core/undo/undobj.cxx", line=1450, function=<optimized out>) at assert.c:92

-> same as in bug #131147 which is already bibisected. Let's mark this a dupe.

*** This bug has been marked as a duplicate of bug 131147 ***