Bug 130774 - Pasting an image in LibreOffice makes pop up a blank rectangle
Summary: Pasting an image in LibreOffice makes pop up a blank rectangle
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-19 11:58 UTC by launatheo
Modified: 2020-05-01 10:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description launatheo 2020-02-19 11:58:14 UTC
Description:
This happens randomly. The image only appears after multiple tries. The document is opened from a NTFS Windows partition.

Steps to Reproduce:
1. Copy an image from Internet
2. Paste it in LibreOffice

Actual Results:
2/3 of the time, it makes pop up a blank rectangle. Only after several tests, the image is displayed correctly.

Expected Results:
The pictures should be displayed directly.


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: fr
Module: PresentationDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes

Version: 6.3.4.2
Build ID: 1:6.3.4-0ubuntu0.19.10.1
Threads CPU : 8; OS : Linux 5.3; UI Render : par défaut; VCL: kde5; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded
Comment 1 ian 2020-02-19 14:32:43 UTC
Thank you for reporting the bug. 

Do you notice any patterns with regards to the image pasting? 
For example: do you have trouble with only large images?

Having this information will help us verify the bug.

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested information is provided.
Comment 2 launatheo 2020-02-19 18:32:15 UTC
No, this applies to any kind of images. But the blank rectangle that pops up always have the same size.
Comment 3 QA Administrators 2020-02-19 18:58:42 UTC Comment hidden (obsolete)
Comment 4 Oliver Grimm 2020-03-24 22:01:43 UTC
How exactly did you "copy" the image from the internet? 
Please provide a step-by-step description.

If you are copying the image with a right click context menu from within a web browser please provide a URL and image description so we can try to reproduce it from there.

Can you successfully paste images into applications other than LibreOffice, e.g. GIMP or KolourPaint?

Which browser are you using when you encounter this bug?

Your version info says you are using KDE, where image copying out of a browser usually works fine. Please try to reproduce this bug with other browsers and other desktop environments (GNOME, LXDE/openbox).
Comment 5 launatheo 2020-03-26 16:21:24 UTC
I've copied it with a right-click. 

I've tried with these two images: https://i.ytimg.com/vi/fDm8JdCAPeM/maxresdefault.jpg [image of cactus] and http://i.ytimg.com/vi/ypG3yBxgDEs/maxresdefault.jpg [landscape] 

It does the same thing if I copy them directly from the search engine or opening them in a new tab and then copying them.

Pasting them with <Ctrl-v> or with the right-click menu within Libreoffice produces the same result : the blank rectangle.

I've tried with Opera beta 68.0.3618.5 and firefox 74: it produces the same result.
I've tried with Onlyoffice Presentation: pasting works fine in each cases.
Comment 6 QA Administrators 2020-03-27 07:44:26 UTC Comment hidden (obsolete)
Comment 7 Timur 2020-03-31 07:24:34 UTC
Let's guess that this is a duplicate of bug 113814.
You may wait until that one is fixed and test master.
And you may now test gtk3 to see if not happening.

*** This bug has been marked as a duplicate of bug 113814 ***
Comment 8 Xisco Faulí 2020-03-31 09:24:34 UTC
I can't reproduce it in

Version: 6.4.0.0.alpha1+
Build ID: 9bc848cf0d301aa57eabcffa101a1cf87bad6470
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

seems to be related to kde5.

@Michael, do you reproduce this on your end ?
Comment 9 Michael Weghorn 2020-03-31 14:56:15 UTC
I cannot reproduce with

Version: 7.0.0.0.alpha0+
Build ID: aa24771563425072c710e8c426323ed311437f13
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: kf5; 
Locale: en-US (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

(Copying the two mentioned images from Firefox to Impress works just fine.)

@launatheo: Can you try whether this issues is also reproducible with a current daily build from TDF rather than the Ubuntu-provided packages?
Those are available at [1] and you can install them in parallel as described at [2].

Also, is the issue also reproducible when you start LibreOffice from the command line using this command?

  SAL_USE_VCLPLUGIN=gtk3 libreoffice

[1] https://dev-builds.libreoffice.org/daily/master/current.html
[2] https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 10 launatheo 2020-05-01 08:08:11 UTC
LibreOffice has been updated to 6.4.2.2 with Kubuntu 20.04 and the issue doesn't happen anymore.
Comment 11 Xisco Faulí 2020-05-01 10:42:36 UTC
(In reply to launatheo from comment #10)
> LibreOffice has been updated to 6.4.2.2 with Kubuntu 20.04 and the issue
> doesn't happen anymore.

Good to hear.
Closing as RESOLVED WORKSFORME