Bug 130829 - XLSX: Pivot Table has two-row headings while in Excel there is only one row, thus causes interoperative issues when formulas are referenced to the pivot table data
Summary: XLSX: Pivot Table has two-row headings while in Excel there is only one row, ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected)
Hardware: All All
: medium normal
Assignee: Not Assigned
Keywords: filter:xlsx
Depends on:
Blocks: Pivot-Table-XLSX
  Show dependency treegraph
Reported: 2020-02-21 06:58 UTC by Kevin Suo
Modified: 2023-01-20 18:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

Test XLSX file (12.10 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-02-21 06:58 UTC, Kevin Suo
expected screenshot (MSO) (4.74 KB, image/png)
2020-02-21 07:02 UTC, Kevin Suo
bad screenshot (Calc) (13.37 KB, image/png)
2020-02-21 07:03 UTC, Kevin Suo

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2020-02-21 06:58:51 UTC
Created attachment 158066 [details]
Test XLSX file

Steps to Reproduce:
1. Open the attached xlsx file with Calc.
2. Compare with MSO ("expected screenshot")

Expected Result:
The formulas in column D should be set on the same rows as "cat" and "dog".

Current Result:
The formulas in column D are set on the wrong rows. Due to this, if you do "Data > Calculation > Force Recalculation (Ctrl + Shift + F9), you will get #VALUE! in cell D4.

Actually the reason for this bug may be due to the fact that Calc inserted a new row (i.e., row 3 which is showing as "Data").

Reproduced in both 6.3 branch and the current master. Fedora 31 x64.
Comment 1 Kevin Suo 2020-02-21 07:02:33 UTC
Created attachment 158067 [details]
expected screenshot (MSO)
Comment 2 Kevin Suo 2020-02-21 07:03:44 UTC
Created attachment 158068 [details]
bad screenshot (Calc)
Comment 3 Durgapriyanka 2020-02-21 17:06:11 UTC
Thank you for reporting the bug. I can confirm the bug present in

Version: (x86)
Build ID: ec7374ff84c71edfbb30d6e4dc5b486b6df7107f
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-11-10_21:37:30
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

and in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-
Comment 4 Kevin Suo 2021-11-04 03:20:41 UTC
Tamás Zolnai: I see you have worked on fixing bug 112733. Maybe you are interested in this one?
Comment 5 Aron Budea 2021-11-07 05:22:33 UTC
This pivot table is in compact form (hinted by the text "Row Labels" in the dropdown), which, as far as I know is not yet supported in Calc.

Comment 6 Simon Dedman 2023-01-20 18:13:30 UTC
Bumping this - I just had a sheet shared from a friend and warned him there's an issue in his calcs not lining up; transpired it's from LOCalc mangling it when it works fine in Excel.

If this is still not supported, that it what it is, but this is potentially a serious point of cross-platform failure (and thus another stick to beat Linux with). Therefore please could this be prioritised to be fixed if now fixable, or, in the interim (either if not fixable or if fixable with a load of work and thus a load of time), can we have something that alerts the user, rather than silently corrupting the data?

1. data & headers in right place but static pasted, not dynamic. Whole pivot section has a comment around it with the generic warning inc pointing to this bug URL.

2. whole pivot section replaced with a block of red background. Each cell or whole section has the same comment per 1.