Download it now!
Bug 130878 - Report does not show label-fields when run in 7.0
Summary: Report does not show label-fields when run in 7.0
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-02-23 04:29 UTC by Drew Jensen
Modified: 2020-03-10 09:35 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
example database (294.84 KB, application/vnd.oasis.opendocument.database)
2020-02-23 04:29 UTC, Drew Jensen
Details
report from version 6.4 (correct) (25.36 KB, application/vnd.oasis.opendocument.text)
2020-02-23 04:30 UTC, Drew Jensen
Details
report from version 7.0 (incorrect) (22.85 KB, application/vnd.oasis.opendocument.text)
2020-02-23 04:30 UTC, Drew Jensen
Details
gdb trace (59.94 KB, text/plain)
2020-02-23 10:12 UTC, Julien Nabet
Details
output after the fix (40.20 KB, application/vnd.oasis.opendocument.text)
2020-03-02 15:04 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Drew Jensen 2020-02-23 04:29:11 UTC
Created attachment 158107 [details]
example database

Tested on Ubuntu 18.04
Version: 7.0.0.0.alpha0+
Build ID: a545e25314d464c190d9d504d78ec6cb67ead4fd

1: load attached test file

2: open form bill_customer (allow macro execution)

3: click on the print button on the form

result: two page bill (report) is displayed read only, there are sections of the header missing and missing text before a sub_total value on page 2.

expected: the report to run as it does in version 6.4

Attached reports produced by both the 6.4 and 7.0 binaries.
Comment 1 Drew Jensen 2020-02-23 04:30:08 UTC
Created attachment 158108 [details]
report from version 6.4 (correct)
Comment 2 Drew Jensen 2020-02-23 04:30:41 UTC
Created attachment 158109 [details]
report from version 7.0 (incorrect)
Comment 3 Robert Großkopf 2020-02-23 08:07:00 UTC
It has nothing to do with the header or any section.

All the label fields are missing when I open the same report in LO 7, which works well in LO 6.4.0.3.

Tested with
Version: 7.0.0.0.alpha0+
Build ID: fef40fd13ec1739f5308d1ff3bcc2291e7a5d96f
CPU threads: 6; OS: Linux 4.12; UI render: default; VCL: kf5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-02-22_03:27:06
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: threaded

on OpenSUSE 15.1 64bit rpm Linux.
Comment 4 Julien Nabet 2020-02-23 10:12:31 UTC
Created attachment 158115 [details]
gdb trace

On pc Debian x86-64 with master sources updated today, I could reproduce this.

I noticed these traces on console but don't know what could be the root cause.
Comment 5 Julien Nabet 2020-02-23 10:14:47 UTC
Let's increase the importance since:
- it's reproduceable each time
- it's a regression
- not a corner case (at least when using reports)

Alex: could you give a try on MacOs? Perhaps with last patches from Stephan, you may be able to build master sources on MacOs now.
Comment 6 Drew Jensen 2020-02-23 15:32:19 UTC
Ok bibisect shows that the anomaly arrived with commit:
357bf8984ada1259720903ad7c7c44c9a6551cc8

Convert reportdesign to fastparser, author Noel Grandin

Adding Noel to CC
Comment 7 Commit Notification 2020-02-29 11:06:22 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/db7df91ea05f9093955583f165e32e218364fec3

tdf#130878 Report does not show label-fields

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2020-03-02 15:03:56 UTC
Hi Noel,
it seems the issue is not completely fixed. After db7df91ea05f9093955583f165e32e218364fec3, the image and text are displayed, however, the generated document has 42 pages, it should have only 2
Comment 9 Xisco Faulí 2020-03-02 15:04:56 UTC
Created attachment 158313 [details]
output after the fix
Comment 10 Commit Notification 2020-03-09 09:12:23 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cb5fc86005a85af06d8ad0bf1ac7aab7649c0048

tdf#130878 improvement to previous fix

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2020-03-10 09:35:20 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: a11c10a83f6fceae6cfb519725d06f8eaf1013fb
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Noel, thanks for fixing this issue!!