Bug 130895 - Insert > Table of Contents and Index > Bibliography Entry > Edit dialog is too tall/high, OK/Cancel button not visible
Summary: Insert > Table of Contents and Index > Bibliography Entry > Edit dialog is to...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.5.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.3.0
Keywords:
Depends on:
Blocks: Bibliography GTK3-Dialog-High
  Show dependency treegraph
 
Reported: 2020-02-24 09:24 UTC by Kevin Suo
Modified: 2021-11-20 01:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Full desktop screenshot (185.76 KB, image/png)
2020-02-24 09:25 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2020-02-24 09:24:22 UTC
Description:
In Writer, go to Insert > Table of Contents and Index > Bibliography Entry, then click "Edit", which opens the Bibliography Entry Edit dialog. This dialog is too tall/high on my screen, a portion of the entry records as well as the OK/Cancel buttons are not visible. 

Steps to Reproduce:
1. Create a new Writer document.
2. Go to Insert > Table of Contents and Index > Bibliography Entry.
3. Click "Edit".

Actual Results:
Some entry records are not visible, and the OK/Cancel buttons are not visible.

Expected Results:
All contents are visible on the screen. If there are to much content to be shown, then there would be a scroll bar to let the user scroll to see everything.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Fedora 31 x64 with Gnome desktop.

Version: 6.3.5.2
Build ID: dd0751754f11728f69b42ee2af66670068624673
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: zh-CN (zh_CN.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Kevin Suo 2020-02-24 09:25:09 UTC
Created attachment 158134 [details]
Full desktop screenshot
Comment 2 Brian 2020-03-05 11:33:34 UTC
It might be related but the Special Character dialog box was initially similar. It looked like it was scaled up and the top bar (and bottom) was completely off the screen and impossible to move or close. The first few times I opened the program the main window was very small (maybe the minimum GUI size). It was like this out of the box on Ubuntu 19.04 (Build ID: libreoffice-6.4.1.2-snap1, 2560x1440 screen). I'm not sure what I did but it's normal now (even after a profile reset). A parallel installation of Version: 6.4.2.1 Build ID: c92dba0b4728c0ec26c4b83e2c0fbf3284425375 seems to be ok.
Comment 3 Heiko Tietze 2020-03-18 18:54:36 UTC
Terrible dialog, sure. Should we make this a duplicate of bug 73275?
Comment 4 Kevin Suo 2021-11-17 14:45:52 UTC
(In reply to Heiko Tietze from comment #3)
I don't think it is a duplicate. I see they are different aspects.

This dialog remains terrible on low resolution display. On my high definition display it looks better due to my screen can show more content. There at least should be a scroll bar, and the spaces between different item rows should be narrower.
Comment 5 Commit Notification 2021-11-19 16:27:55 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1833cb7aa9d8cc3e172c59f8dc25cd4ca6622a50

Resolves tdf#130895 - Edit Bookmark Entry dialog too tall

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Kevin Suo 2021-11-20 01:36:40 UTC
Verified fixed on "master".