Bug 130906 - [RFE] Copy a slide with source document proportions
Summary: [RFE] Copy a slide with source document proportions
Status: RESOLVED DUPLICATE of bug 112697
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-02-24 16:34 UTC by Konstantin Kharlamov
Modified: 2020-05-11 09:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Kharlamov 2020-02-24 16:34:54 UTC
Upon pasting a slide from a presentation with different proportions, LO asks whether the user want to scale objects to fit the destination proportions. But there's no option "Apply source document proportions".

Per the user's experience, MS Power Point offers such option, and it would be great if LO would offer it too.

# Steps to reproduce

1. Start Libreoffice Impress (Once Impress loaded, "Select Template" window should
appear)
2. In "Select Template" window that popped up choose `Alizarin` theme.
3. Select first slide, and press Ctrl+c to copy the slide
4. Press Ctrl+n to open new Impress instance
5. Press Ctrl+v to paste the slide. A dialog should pop up that says "The page size of the target document is different than the source document"

## Expected

The dialog, among other options, would ask whether a user wants to apply page size of the source document.

## Actual

There're options to fit the target page size, but no option to apply the source page size.
Comment 1 Konstantin Kharlamov 2020-02-24 16:55:43 UTC
I was asked to add some details on the PowerPoint implementation: MS documentation says

> To maintain the theme of presentation you are copying from, click "Keep Source
> Formatting". This implies that the slide will keep its original theme format and
> not presentation's theme

Source: https://support.office.com/en-us/article/copy-and-paste-your-slides-1fe39ace-4df6-4346-b724-30a6e2c0aeab
Comment 2 Heiko Tietze 2020-05-11 09:01:50 UTC
Similar issue with master slides. Let's have the discussion on bug 112697.

*** This bug has been marked as a duplicate of bug 112697 ***