Download it now!
Bug 130920 - Running Basic code; error when viewing field value
Summary: Running Basic code; error when viewing field value
Status: RESOLVED DUPLICATE of bug 57307
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: BASIC-IDE
  Show dependency treegraph
 
Reported: 2020-02-25 09:09 UTC by Philip Russell
Modified: 2020-04-28 10:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Russell 2020-02-25 09:09:04 UTC
When running & stepping through Basic code in the editor you can hover the cursor over (some types) field and it shows the fields value, without the need to enter the field's name in the Watch. However it appears to have a problem if there is an underscore in the field name. For example I have 2 fields, nCol & nCol_A and when I hover over nCol_A it shows and gives the value of nCol. nCol is global and nCol_A is local. The problem is solved by renaming nCol_A as nColA.
Simple to reproduce:

Dim nCol   as Integer
Dim nCol_A as Integer
nCol = 5
nCol_A = 10

Hover over nCol_A and it says nCol = 5
Comment 1 Oliver Brinzing 2020-02-25 17:53:28 UTC
REM  *****  BASIC  *****

Sub Main
 Dim nCol   as Integer
 Dim nCol_A as Integer
 nCol = 5
 nCol_A = 10
 MsgBox nCol & " " & nCol_A
End Sub

reproducible with:

Version: 6.4.1.1 (x64)
Build-ID: 56f3c78975db08733f771c53643b5d1aa7c57567
CPU-Threads: 4; BS: Windows 10.0 Build 18363; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: 

AOO 4.1.5
Comment 2 Oliver Brinzing 2020-02-25 17:55:07 UTC
but *not* reproducible with:

Version: 7.0.0.0.alpha0+ (x64)
Build ID: dcafbe29105c13fe940b24ba69e669b680c44962
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

seems to be fixed an current master
Comment 3 raal 2020-02-25 21:18:40 UTC
work for me in Version: 7.0.0.0.alpha0+
Build ID: f32a59a52e3ee2a0a8df9bb76bc1ff0ada7c7f1d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 

Please test it
http://dev-builds.libreoffice.org/daily/master/
Thank you
Comment 4 Andreas Heinisch 2020-04-28 10:05:52 UTC
Should be solved in Version 7.0.0.0.alpha0+ with https://gerrit.libreoffice.org/c/core/+/88575

*** This bug has been marked as a duplicate of bug 57307 ***