Download it now!
Bug 130960 - edit / track changes / compare documents does not work
Summary: edit / track changes / compare documents does not work
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-02-26 14:55 UTC by Elmar
Modified: 2020-04-14 20:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
file 1 (34.71 KB, application/vnd.oasis.opendocument.text)
2020-02-26 15:00 UTC, Elmar
Details
file 2 (24.70 KB, application/vnd.oasis.opendocument.text)
2020-02-26 15:02 UTC, Elmar
Details
compare done with Writer v6.0 (36.19 KB, application/vnd.oasis.opendocument.text)
2020-02-26 15:03 UTC, Elmar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elmar 2020-02-26 14:55:04 UTC
Description:
I try to compare a document to another but no differences are identified

Steps to Reproduce:
1. modify a document without tracking enabled
2. save to new name
3. open one, compare documents

Actual Results:
No differences identified

Expected Results:
Differences between the two documents should be highlighted


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-GB
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 Elmar 2020-02-26 15:00:13 UTC
Created attachment 158203 [details]
file 1
Comment 2 Elmar 2020-02-26 15:02:02 UTC
Created attachment 158204 [details]
file 2
Comment 3 Elmar 2020-02-26 15:03:42 UTC
Created attachment 158205 [details]
compare done with Writer v6.0

Seems to be a regression - works correctly when using LO Writer v6.0
Comment 4 Elmar 2020-02-26 15:04:23 UTC
Seems to be a regression. I tried with v6.0 and got a good result.
Comment 5 Xisco Faulí 2020-02-26 17:32:28 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=0528012fd0dc4b93645ef7790b0db9d1cecbae66

author	Noel Grandin <noel.grandin@collabora.co.uk>	2020-02-03 10:05:12 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2020-02-03 10:53:01 +0100
commit	0528012fd0dc4b93645ef7790b0db9d1cecbae66 (patch)
tree	e3adb8f0200fc95c06f62205b346244c79ae88ca
parent	f612839ed9200a3900ae5c3a2e12beccfa37b11e (diff)
loplugin:constantparam

Bisected with: bibisect-linux64-6.5

Adding Cc: to Noel Grandin
Comment 6 Commit Notification 2020-02-27 10:36:54 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5c3dae90e9bd0232ea790c1a79eaefaf2b74a144

tdf#130960 compare documents does not work

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2020-02-27 16:31:38 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: 74e3c95b9b628a0b326790b62b4e378a12d02997
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Noel, thanks for fixing this issue!!
Comment 8 Commit Notification 2020-03-03 22:18:58 UTC Comment hidden (obsolete)
Comment 9 Commit Notification 2020-04-14 20:20:33 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4a581f12e0d0fa105f053904300b729acb18194a

tdf#130960: Add UItest

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.