Bug 131054 - Start Center height can not be changed in non-maximised state with a screen height less than 768
Summary: Start Center height can not be changed in non-maximised state with a screen h...
Status: RESOLVED DUPLICATE of bug 119447
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-01 19:37 UTC by satovey@yhoo.com
Modified: 2020-06-17 11:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description satovey@yhoo.com 2020-03-01 19:37:51 UTC
Description:
When starting LibreOffice portable: LibreOffice 6.4.0.3 (x86) on Windows 7 Pro x64 with screen resolution of 1280x720, LibreOffice startup is at a managed size. 

When I attempt to increase the vertical hight of the app window so that I can view all the button options, it expands to a hight larger than my desktop window and the bottom of the window stretches down past the windows bar and below the window.

At this point, the width will reduce in size but the height remains static and there is not way to access the buttons that are off screen.

I ran it in safe mode and the same issue occurs.

I could not check the openGLl issue because I am not authorized to access the openGL addon page and there's only so much I am willing to attempt when dealing with such idiocy as this.

Steps to Reproduce:
1. Set screen resolution to 1280x720
2. Click on LibreOffice shortcut.
3. After LibreOffice startup has started, click the bottom window border and attempt to lengthen the height.
4. After LibreOffice start up has increased out of control, click on the top window border and attempt to reduce the height.

Actual Results:
I would provide screen shots but you do not have an upload link.
And quite frankly, if you cannot understand my previous instructions without asking for more details, you have absolutely no business being a developer.

Expected Results:
I expect the height to be adjustable like any reasonable program would be rather than being set to a default height that requires me to increase my screen resolution to the point of my not being able to see and use my computer.

Whoever made this default decision is clearly: A BONAFIDE IDIOT!


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.4.0.3 (x86)
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 8; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-03-17 10:08:47 UTC
Thanks for reporting this issue.
Could you please try to reproduce it with the version from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present.
Comment 2 satovey@yhoo.com 2020-03-17 21:39:54 UTC
The problem is reproduced with the version at the link 6.4.1.
I wonder if this is a bug in the compiler or the GUI library that is being used?
I know that with Visual Studios, you can set a window to not size, 
if this is the case with the GUI Library that LibreOffice uses, and that property is set to resize, then perhaps it's a bug in the library.
Comment 3 QA Administrators 2020-03-18 02:42:16 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2020-05-16 12:59:26 UTC
I tried with 800x600 and indeed the problem is only visible, if the window is not maximised. For the issue of reaching the application buttons from the start center, there is bug 119447. Would you be happy, if the request in bug 119447 was implemented?

The commit for implementing a minimum height for the Start Center is:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=840e7f004354ebe1239b9271dd758839c477ca7c

Quoting from the commit msg:
"This minimum size calculated like this:
width: sidebar optimal width + width of text appearing in
the thumbnail view when no recent document is available.
height: menu width + optimal width of GtkBox containing
buttons."

Note that the minimum height only affects Start Center, not the application windows.
Comment 5 Xisco Faulí 2020-06-17 11:06:42 UTC
I think we can close this a duplicate of bug 119447

*** This bug has been marked as a duplicate of bug 119447 ***