Bug 131072 - RTF: frames obscure the text under/inside them (Wrap Through), wrap setting change not saved
Summary: RTF: frames obscure the text under/inside them (Wrap Through), wrap setting c...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Anchor-and-Text-Wrap Frame RTF-Shapes
  Show dependency treegraph
 
Reported: 2020-03-02 13:17 UTC by Petr Prikryl
Modified: 2021-06-13 12:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The sample file that shows the problem. (12.16 KB, application/rtf)
2020-03-02 13:20 UTC, Petr Prikryl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Prikryl 2020-03-02 13:17:15 UTC
Description:
(I am new to LibreOffice, but I like it. Sorry if I do not use the correct terms. I am also new to this Bugzilla, and I was not able to find, whether the bug was reported earlier. Sorry if it was.)

The RTF document (I can send a small example) was originally created in MS Word. The heading part and part of the content was created with frames/tables (?) around the text.

I believe it worked fine with LibreOffice Writer 6.3.4. After switching to 6.4.1, the texts in the document that were framed are not shown -- just empty rectangles.

A RTF browser (MS Windows, Total Commander, F3 - Lister) shows the content is there.

When experimenting with the file, right-mouse button click (context menu) + Wrap > In Background causes the text appear. (The Wrap Through is set by default.)

I do not know the internals, but the rectangles are as if white-colour filled instead of transparent.

Steps to Reproduce:
1. Open the specific RTF document. (Text in the frame is not visible.)
2. Mouse right click -- Wrap -- In Background -- this makes it visible.
3. Save (without changing the format) and open again -- not visible again.

Actual Results:
Text invisible (obscured by the white area of the frame).

Expected Results:
Text visible.


Reproducible: Always


User Profile Reset: No



Additional Info:
I do not know how to send the file sample.
Comment 1 Petr Prikryl 2020-03-02 13:20:12 UTC
Created attachment 158311 [details]
The sample file that shows the problem.
Comment 2 Petr Prikryl 2020-03-02 13:58:18 UTC
To add: This is not related to tables. It is related to Frames.

I believe it worked differently in 6.3.4, but I am not sure actually (working on  more computers).
Comment 3 Durgapriyanka 2020-03-03 17:52:31 UTC
Thank you for reporting the bug. I can confirm the bug present in

Version: 6.4.0.0.alpha1+ (x86)
Build ID: ec7374ff84c71edfbb30d6e4dc5b486b6df7107f
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-11-10_21:37:30
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
	

But, not in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 4 Dieter 2020-03-03 19:09:26 UTC
(In reply to Durgapriyanka from comment #3)
> Thank you for reporting the bug. I can confirm the bug present in
> 
> Version: 6.4.0.0.alpha1+ (x86)

=> NEW
Comment 5 stragu 2021-06-13 12:03:10 UTC
Can reproduce in:

Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: bb54d6d8241a06a6772052b77b67d6a4f686426c
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-06-11_20:14:38
Calc: threaded

I believe the issue with empty frames hiding text is described in Bug 71920. (But interestingly, it's thought to be inherited from OpenOffice in that bug...)

I can confirm that the issue with not saving the "Background wrap" setting is specific to RTF, as converting to ODT keeps the setting when reopened.