Download it now!
Bug 131095 - Reapply (same) autofilter to new values
Summary: Reapply (same) autofilter to new values
Status: RESOLVED DUPLICATE of bug 130770
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.5.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-03 13:40 UTC by Scito
Modified: 2020-03-03 16:33 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Column A with "0" and "1" values (7.36 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-03-03 13:42 UTC, Scito
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Scito 2020-03-03 13:40:35 UTC
Description:
The autofilter of an auto-filtered column is not reapplied, after opening and applying, despite having new data to filter.

Steps to Reproduce:
1. Create a new Calc document
2. Create one column with header "A" and columns values "0" and "1", example
    A   <- column header
    1
    1
    0
    1
    0
2. Create an autofilter on column header "A"
3. Filter all "1" values using the autofilter by deselecting the "1" checkbox, press OK
4. -> Only "0" values are shown (expected behavior)
5. Add new values to the column "A": some "0" and some "1" values, example
    1
    0
    1
    0
6. Open the autofilter again
7. Filter (again) all "1" values using the autofilter keeping the "1" checkbox deselected. Press OK.


Actual Results:
-> Nothing happens, the autofilter is not applied.
The newly added "1" values are shown despite the autofilter has been accepted with OK.

Expected Results:
The autofilter is applied to the new data: All "1" values should be filtered out including the newly added "1" values


Reproducible: Always


User Profile Reset: No



Additional Info:
Workaround:
a) The "1" values must be selected again, i.e. no filter is applied. Press OK.
b) -> All "1" and "0" values are printed.
c) Then open the autofilter and filter all the "1" values by deselecting the "1" checkbox.
d) -> Only "0" values are shown, all "1" values are filtered out (the expected behavior)

Version: 6.3.5.2
Build ID: 30(Build:2)
CPU threads: 4; OS: Linux 4.12; UI render: GL; VCL: kde5; 
Locale: de-CH (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Scito 2020-03-03 13:42:53 UTC
Created attachment 158339 [details]
Column A with "0" and "1" values
Comment 2 Julien Nabet 2020-03-03 16:33:33 UTC

*** This bug has been marked as a duplicate of bug 130770 ***