Bug 131155 - Sorting - Move 'Range contains column labels' from 'Options' tab to 'Sort Criteria' tab
Summary: Sorting - Move 'Range contains column labels' from 'Options' tab to 'Sort Cri...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.1.2 release
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.4.0
Keywords: difficultyMedium, easyHack, skillCpp, topicUI
: 143026 (view as bug list)
Depends on:
Blocks: Sorting
  Show dependency treegraph
 
Reported: 2020-03-05 13:25 UTC by Thanos Massias
Modified: 2022-05-23 07:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thanos Massias 2020-03-05 13:25:05 UTC
Description:
User experience when sorting (Data > Sort...) would be improved if the 'Range contains column labels' option was moved from the 'Options' tab to the 'Sort Criteria' tab. In this way, the user does not need to navigate between tabs for what is probably the most common change in options.

As an example, versions of MS Office have the equivalent 'My data has headers' option at the top-right corner of the main tab.

Steps to Reproduce:
none

Actual Results:
none

Expected Results:
none


Reproducible: Always


User Profile Reset: No



Additional Info:
none
Comment 1 Heiko Tietze 2020-05-18 10:43:16 UTC
Admitted, that switching to Options is almost always needed and an annoying step. But it seems to be a bottom less to move one option. 

Eike: Any blocker to move some/many/all options to the criteria tab? We could introduce a two column layout with keys to the left and options right-hand.
Comment 2 Eike Rathke 2020-05-18 16:00:25 UTC
No general objection. However, moving all from Options over to Sort Criteria may be too much, also given some listboxes may need their width, depending on content. There is enough space available under the Sort Keys on Sort Criteria. But what should be kept together is Direction and "Range contains ..." because when switching Direction from sort rows to sort columns the option changes from "Range contains column labels" to "Range contains row labels".
Comment 3 Heiko Tietze 2020-05-28 12:41:22 UTC
Approved by UX. Let's start simple and move just the one option as requested here. Could be an easyhack.
Comment 4 stragu 2021-06-24 13:24:00 UTC
*** Bug 143026 has been marked as a duplicate of this bug. ***
Comment 5 Antonio 2021-06-24 14:19:27 UTC
Hi can see on Comment 3 that was agreed that would be a great improvment to sort. But this comment is one year over and nothing happens.
it does not look as amjor change, what can we do to put it in agenda?
Comment 6 Eike Rathke 2021-06-25 10:17:13 UTC
(In reply to Antonio from comment #5)
> it does not look as amjor change, what can we do to put it in agenda?
Work on the change and make it happen.


(In reply to Heiko Tietze from comment #3)
> Could be an easyhack.
Pointers to the relevant .ui definition file and appropriate EasyHack keywords would be welcomed.
Comment 7 Heiko Tietze 2021-06-28 08:58:54 UTC
Code pointer:
sc/uiconfig/scalc/ui/sortoptionspage.ui  - GtkCheckbox with id "header"
sc/uiconfig/scalc/ui/sortcriteriapage.ui
sc/source/ui/dbgui/tpsort.cxx

Might be a bit tricky to connect the m_xBtnHeader at the new place.
Comment 8 Antonio 2021-06-28 11:32:18 UTC Comment hidden (off-topic)
Comment 9 Heiko Tietze 2021-06-28 14:05:08 UTC Comment hidden (off-topic)
Comment 10 Allison King 2022-03-01 20:53:33 UTC
for the life of me, I don't understand why the "range contains column labels" option isn't on the sort criteria tab. Virtually every other spreadsheet does it. Would really love to see this change.
Comment 11 Laurent BP 2022-04-30 10:03:43 UTC
@Heiko
I see you assigned the bug to yourself. May I work on it and propose a patch on gerrit?
Comment 12 Heiko Tietze 2022-05-02 07:20:51 UTC
(In reply to Laurent BP from comment #11)
> @Heiko
> I see you assigned the bug to yourself. May I work on it and propose a patch
> on gerrit?

Forgot the WIP patch https://gerrit.libreoffice.org/c/core/+/130843 :-)
Do you want to continue from there or start from scratch? Or shall I finish the work (don't remember why I stopped).
Comment 13 Laurent BP 2022-05-02 07:55:30 UTC
(In reply to Heiko Tietze from comment #12)
> (In reply to Laurent BP from comment #11)
> > @Heiko
> > I see you assigned the bug to yourself. May I work on it and propose a patch
> > on gerrit?
> 
> Forgot the WIP patch https://gerrit.libreoffice.org/c/core/+/130843 :-)
> Do you want to continue from there or start from scratch? Or shall I finish
> the work (don't remember why I stopped).

You're the expert ;-)
I started here:
https://gerrit.libreoffice.org/c/core/+/133658
I duplicated only "Header" check box till now.

Choose which change is the most promising :-)
Comment 14 Commit Notification 2022-05-23 07:03:21 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7c2bcac3e6aac31811adede6f466d2125184da4c

Resolves tdf#131155 - Keep frequently used options on sort criteria tab

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.