Download it now!
Bug 131232 - Feature request: Don't require space to change a character in Auto Correct
Summary: Feature request: Don't require space to change a character in Auto Correct
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2020-03-09 12:07 UTC by Steve Boatman
Modified: 2020-03-20 16:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Boatman 2020-03-09 12:07:41 UTC
Description:
There are several ways to input a spanish ñ into Writer but they're all combersome. An easy way is to create a key combination in Auto Correct except it doesn't work in the middle of a word, it requires a space before the the desired letter. Removing the need for a preceeding space would make this really easy for all special characters to be entered wherever they were wanted.

Steps to Reproduce:
1.add n/ in the Replace box of Auto Correct Options and ñ in the With box
2.type man/ana
3.LO has man/ana and doesn't replace the n/ with ñ

Actual Results:
1.add n/ in the Replace box of Auto Correct Options and ñ in the With box
2.type man/ana
3.LO has man/ana and doesn't replace the n/ with ñ

Expected Results:
Auto Correct as mañana after replacing the n/ with ñ


Reproducible: Always


User Profile Reset: No



Additional Info:
LO should Auto Correct as mañana after replacing the n/ with ñ

This is one example. LO should replace any unique character combo with the desired replacement regardless of having a preceeding space or not.
Comment 1 Dieter 2020-03-17 11:25:32 UTC
I can't reproduce this. I added :n: to replaced by ñ and it worked. Does this solve your problem?

=> NEEDINFO
Comment 2 Steve Boatman 2020-03-17 14:50:54 UTC
OK - using your example it works. I had been using /n as the shortcut and it works only if there us a oreceedubg soace. It looks like I need something before and after the n.

Thanks
Comment 3 QA Administrators 2020-03-18 02:42:33 UTC Comment hidden (obsolete)
Comment 4 Dieter 2020-03-20 16:55:13 UTC
(In reply to Steve Boatman from comment #2)
> OK - using your example it works. I had been using /n as the shortcut and it
> works only if there us a oreceedubg soace. It looks like I need something
> before and after the n.
> 
> Thanks

=> RESOLVED NOTABUG