Bug 131313 - Long FILESAVE passwords cause FILEOPEN errors in LibreOffice v6.4.1.2, under MacOS 10.14.6 64bit
Summary: Long FILESAVE passwords cause FILEOPEN errors in LibreOffice v6.4.1.2, under ...
Status: RESOLVED DUPLICATE of bug 65492
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-12 16:08 UTC by keith
Modified: 2020-06-23 17:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description keith 2020-03-12 16:08:24 UTC
Description:
If I save a Calc spreadsheet in Microsoft Excel format, and give it a password, it saves correctly.
When I try to open it (with LO), it asks for a password but does not always recognise it. For example,
The saved p/w "Thedeerhunter-22" produces a "wrong password" error message.
The saved password "horses" allows a file to be re-opened.
The same problem occurs when opening the LO file in Microsoft Office.
Is this a problem of password length or invalid - character?


Steps to Reproduce:
1.Create a new Calc spreadsheet,
2.Save it with a password, then quit LO.
3.Right-click on the file to open in LO and enter the password.

Actual Results:
File opens if saved using short password above.
File does not open if saved with long password above, with the error message "The password is incorrect. The file cannot be opened."

Expected Results:
The "save as" dialogue should prevent the use of invalid password formats.
The "open" dialogue should respect the saved password.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.1.2
Build ID: 4d224e95b98b138af42a64d84056446d09082932
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: GL; VCL: osx; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Ahmad Haris 2020-03-22 11:57:26 UTC
I can't reproduce this bug. can you write down "the long password"?

Version: 6.4.2.2
Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
CPU threads: 8; OS: Mac OS X 10.15.3; UI render: GL; VCL: osx; 
Locale: en-ID (en_ID.UTF-8); UI-Language: en-US
Calc: threaded
Comment 2 keith 2020-03-22 13:54:29 UTC
(In reply to Ahmad Haris from comment #1)
> I can't reproduce this bug. can you write down "the long password"?
> 
> Version: 6.4.2.2
> Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
> CPU threads: 8; OS: Mac OS X 10.15.3; UI render: GL; VCL: osx; 
> Locale: en-ID (en_ID.UTF-8); UI-Language: en-US
> Calc: threaded


Hi Ahmad.
As I said in my original bug submission (I quote)

"The saved p/w "Thedeerhunter-22" produces a "wrong password" error message.
The saved password "horses" allows a file to be re-opened.”

The long p/w is Thedeerhunter-22

Keith
Comment 3 steve 2020-04-29 09:07:00 UTC
macOS 10.15.4
LibreOffice 6.4.3.2

Reproduce:
1. Create new Calc spreadsheet
2. Save with password "Thedeerhunter-22" in .xlsx file format
3. quit LO
4. open file with LO

Currently
LO asks for password, enter "Thedeerhunter-22", file opens fine.

@Keith: Can you please test 6.4.3.2 and see if the problem persist for you. If yes, please reset the bug to UNCONFIRMED if no please close as WORKSFORME.
Comment 4 keith 2020-04-29 13:39:41 UTC
I just downloaded and installed 6.4.3.2 and tested with password Thedeerhunter-22. The problem still exists, I still get the message "The password is incorrect. The file cannot be opened.”

One question: I am saving in Excel 97-2003 (*.xls) format. Did you test that?

Keith
Comment 5 eisa01 2020-05-02 16:17:41 UTC
MSO Excel only supports 15 character passwords up to version 2003: https://docs.microsoft.com/en-us/openspecs/office_file_formats/ms-xls/a3ad4e36-ab66-426c-ba91-b84433312068

If I paste your password into the password field when saving in LO I get a pop-up saying it was truncated for being too long. If I try to type it, I'm also restricted in typing longer than 15 characters

Your suggested password was 16 characters, so just remove the last character and the file opens

So this is not a bug

Version: 6.4.3.5
Build ID: 4db9852e73d9e9d662fc8a2783bace79addf1805
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 keith 2020-05-02 17:56:42 UTC
Thanks for the explanation.
I just find it odd that LO allows me to enter a password that is too long, while truncating it without telling me.
Comment 7 Justin L 2020-06-22 18:02:55 UTC
(In reply to keith from comment #6)
> I just find it odd that LO allows me to enter a password that is too long,
> while truncating it without telling me.
Fixed in LO 7.0 thanks to bug 43452.
Comment 8 Justin L 2020-06-23 17:00:13 UTC

*** This bug has been marked as a duplicate of bug 65492 ***