Download it now!
Bug 131316 - CUSTOMISE DIALOG: Feature Request for key sequence mapping
Summary: CUSTOMISE DIALOG: Feature Request for key sequence mapping
Status: RESOLVED DUPLICATE of bug 115052
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Customize-Dialog-Keyboard
  Show dependency treegraph
 
Reported: 2020-03-12 17:19 UTC by Janvi
Modified: 2020-03-16 08:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janvi 2020-03-12 17:19:15 UTC
Customize>Keyboard>Edit is insufficient.  See appended list of sometimes
very old related and existing bugs.  None of this bugs complains about the
missing possibility to assign free key sequences additional to static key
shortcut combinations.  Implementation requires a state machine to the
keyboard input and there are several other editors who do this very nice. 
This feature typically allows (at least partly) emulation of other editors. 
Customization result allows configurations far away from Windows default UI
style.  Once implemented, it can also used to realize any OS or other user flavour editors typical behaviour.  Going back to the roots, the DOS StarWriter by Marco Börries StarDivision was in fact a Wordstar clone who makes extensive use of those shortcut key sequences.  Very effective speed editing without any mouse. Some examples of other editors keymap customizations:

Ultra Edit implemented key sequence feature in latest versions.  
See one of the discussions about here:
http://forums.ultraedit.com/emacs-keybindings-t1875-s10.html

Textmaker is a modern UI multi OS editor what shows nice implementation of
the customize keyboard dialog including free key sequences.  For testing,
please use the demo version of Textmaker included in Softmaker Office. 
Avoid testing Textmaker included in FreeOffice.  FreeOffice disabled this
feature in latest version 2018 while there was a setup for predefined "classic" keymap until version 2016.

Eclipse is a modern multi OS IDE what shows nice implementation of customize
keybard dialog including free key sequences.  Download to test with default
editor is sufficient, no plugin required.  For example of Eclipse custom
keymap plugin configuration, see the IntelliJ keymap project on github.

There are existing Word capabilities  but I wont discuss them  here. 

Related bugs:

115527 Redesign of the keyboard tab of the Customization dialog
70568 Java add-on function inaccessible from Shortcuts Dialog
91724 LO docu is not accessible for blind people
46137 UI: Allow to assign custom keyboard shortcuts
49091 UI: Alt-Left, Alt-Right keyboard shortcuts ineffective
107244 [META] Ctrl+Alt (aka AltGR) keyboard shortcut issues
128537 Fatal Error with accidental CMD + ² key combination
55838 ctrl + end does not jump to end of document
35030 Customize Keyboard Reset button doesn't work
43822 Ctrl+W does not close, and Ctrl+S does not save
82117 Improve shortcut key list for German keyboard layout
88474 EDITING: Selection Mode is Reset to ‘Standard selection’ with Esc
102307 F3 executes uno:RepeatSearch from the FindBar
41560 Customize Dialog Keyboard
45705 Cant assign shortcuts to "Zoom in" and "Zoom out" commands
52335 The GUI for assigning keyboard shortcuts to functions is not intuitive
66975 Option to keep cursor vertically centered in viewport
83538 Indication when a keyboard shortcut is set globally
114133 Combinations with tab key missing in the customization
107282 Deleted customized shortcuts still working
92700 Customize Dialog: Tab Keyboard: missing tool tip
115052 Allow other keys than from US keyboard as shortcut keys
Comment 1 Heiko Tietze 2020-03-16 08:26:02 UTC
(In reply to Janvi from comment #0)
> ...to assign free key sequences

That's bug 115052.

And you are absolutely right, it's definitely needed and therefore on the list of tasks for GSoC, however neither a student is interested nor a mentor volunteered so far https://wiki.documentfoundation.org/Development/GSoC/Ideas_without_a_mentor#Keyboard_customization

The design team made a proposal regarding the UI at https://design.blog.documentfoundation.org/2015/01/22/how-to-make-libreoffice-customization-usable/. And last but not least some work in ongoing to improve the UI https://gerrit.libreoffice.org/c/core/+/90183 though not reworking the internal assignment.

> Ultra Edit..., Textmaker..., Eclipse...

Take also a look on how KDE handles this https://docs.kde.org/trunk5/en/applications/fundamentals/shortcuts.html

*** This bug has been marked as a duplicate of bug 115052 ***