Bug 131336 - Command .uno:MacroDialog (Alt+F11) does no longer work
Summary: Command .uno:MacroDialog (Alt+F11) does no longer work
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Macro
  Show dependency treegraph
 
Reported: 2020-03-14 13:40 UTC by Regina Henschel
Modified: 2020-04-13 11:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the dialog, which should open (33.52 KB, image/png)
2020-03-14 13:40 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2020-03-14 13:40:16 UTC
Created attachment 158676 [details]
Screenshot of the dialog, which should open

Alt+F11 (.uno:MacroDialog) should open the window "Basic Macros", see screenshot. But it does nothing. It fails too, if you add the command to a toolbar.

I see the error in Version: 7.0.0.0.alpha0+ (x64)
Build-ID: 469aea3b3b76926112d7b6fce212be2906842dc9
CPU-Threads: 8; BS: Windows 10.0 Build 18362; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (en_US); UI-Sprache: de-DE
Calc: threaded

It was OK in Version: 6.5.0.0.alpha0+ (x64)
Build ID: 147af9e2cf7f937ed83ab00574b6a418a2cb629e
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL
Comment 1 Julien Nabet 2020-03-14 16:24:39 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this with gtk3 or gen rendering.
(Windows only?)
Comment 2 himajin100000 2020-03-14 19:01:00 UTC
It was reproducible when I was using 2020-02-14 nightly build, which was the last successful build until 2020-03-07, which was when tb77 was restored to normal state.

but with 

バージョン: 7.0.0.0.alpha0+ (x64)
Build ID: 749897d308c41cd5c92eccdd9fc7a5becbcea33c
CPU threads: 4; OS:Windows 10.0 Build 18363; UI render: default; VCL: win; 
ロケール: ja-JP (ja_JP); UIの言語: ja-JP
Calc: CL

I can't reproduce.
Comment 3 Regina Henschel 2020-03-21 13:43:31 UTC
I thought it might be a problem, because I have used an administrative installation. I now have made a clean, regular installation of daily LO with new user profile. The problem is still there. And in addition the dialog "Basic Macro Organizer" is not available. You need it to manage Libraries. The dialog is opened by .uno:MacroOrganizer.

I have tested it with Version: 7.0.0.0.alpha0+ (x64)
Build ID: 6388c578c672690fff662cb04b6a0436cd742f37
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: Skia/Vulkan; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

I have got Oracle Java 9.0.1. Might it be a problem with Java?
Comment 4 himajin100000 2020-03-21 20:29:45 UTC
reproducible again with at least

バージョン: 7.0.0.0.alpha0+ (x64)
Build ID: d43d2662ff64c613740080e166d1046214edb0f0
CPU threads: 4; OS:Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
ロケール: ja-JP (ja_JP); UIの言語: ja-JP
Calc: CL
Comment 5 Regina Henschel 2020-03-23 17:08:59 UTC
Because of comment 4, I set it to new.
Comment 6 Regina Henschel 2020-03-23 23:04:46 UTC
himajin100000@gmail.com: Can you please test, whether macro recording in Writer works for you? That is broken too for me.
Comment 7 himajin100000 2020-03-23 23:16:24 UTC
On SID_RECORDMACRO, a Window with a button "Stop Recording..." appeared, but the button(probably SID_STOP_RECORDING) seemed to do nothing.
Comment 8 himajin100000 2020-03-23 23:18:21 UTC
um, I said "seemed to do nothing", but actually the window itself disappeared.
Comment 9 himajin100000 2020-04-08 08:34:38 UTC
* I was wondering , because the macro organizer window appeared when I used my own libreoffice local build and because the window did not appear when I used the official daily.

* I compared the config for the official daily and my own. 

https://opengrok.libreoffice.org/xref/core/distro-configs/LibreOfficeWin64.conf?r=c625bc9a

and noticed that I wasn't specifying --enable-mergelibs. 

With half-doubted mind, I have been trying to build with the option and with some personal modification to (remove UNLESS_MERGELIBS | add VCL_DLLPUBLIC before SAL_DLLPUBLIC_RTTI for MetaPointAction) that prevented successful build itself.

The result: the window did not appear. 

Can someone try confirming my own result?

FYI:
LibreOffice gerrit has introduced Jenkins to check if the source with proposed patch is still buildable, but it seems Jenkins does not have --enable-mergelibs.

https://opengrok.libreoffice.org/xref/core/distro-configs/Jenkins/windows_msc_dbgutil_32?r=ccdb68fd
Comment 10 himajin100000 2020-04-08 17:08:35 UTC
my own local build says:

warn:sfx.appl:6896:36112:sfx2/source/appl/appserv.cxx:1227: SfxApplication::MacroOrganizer, no symbol!
Comment 11 himajin100000 2020-04-09 20:39:39 UTC
Regina, can you test the next build when it's available?
it should hopefully be available on 2020-04-09T04:00 (UTC) to 2020-04-09T05:00 (UTC)
https://dev-builds.libreoffice.org/daily/master/current.html

at least on my own local build, with the following fix,  it seems ".uno:MacroDialog" is working again.

https://gerrit.libreoffice.org/c/core/+/91961
Comment 12 himajin100000 2020-04-10 04:54:34 UTC
>2020-04-09T04:00 (UTC) to 2020-04-09T05:00
oops, I meant 
2020-04-10T04:00 (UTC) to 2020-04-10T05:00

but Daily builds still not available. Seems we need patience.

https://ci.libreoffice.org/job/lo_daily_tb_win/194/console
Comment 13 Regina Henschel 2020-04-11 20:00:10 UTC
My fresh local build works now too, so I'm confident.
Comment 14 himajin100000 2020-04-12 05:41:31 UTC
confirmed that with official nightly, the command works. Marking RESOLVED FIXED

Version: 7.0.0.0.alpha0+ (x64)
Build ID: b0b9d736fb9ed73e849f80800916466868dbce28
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: ja-JP (ja_JP); UI-Language: en-US
Calc: CL
Comment 17 himajin100000 2020-04-12 20:20:23 UTC
done.
https://gerrit.libreoffice.org/c/core/+/92077
Comment 18 Regina Henschel 2020-04-13 11:14:51 UTC
It works again. Thank you.

Seen correct in Version: 7.0.0.0.alpha0+ (x64)
Build ID: 4475bcd83aac7e033fc5250f268eb922bd471e7b
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: Skia/Vulkan; VCL: win; 
Locale: de-DE (en_US); UI-Language: en-US
Calc: CL