Download it now!
Bug 131423 - Function Wizard in Calc allows too many parameters
Summary: Function Wizard in Calc allows too many parameters
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0 all versions
Hardware: All All
: medium normal
Assignee: Eike Rathke
URL:
Whiteboard: target:7.0.0 target:6.4.4 target:7.1....
Keywords:
: 131657 (view as bug list)
Depends on:
Blocks: Function-Wizard
  Show dependency treegraph
 
Reported: 2020-03-19 13:20 UTC by Steve Fanning
Modified: 2020-05-30 00:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of IMPRODUCT function parameters problem (13.10 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-03-19 13:20 UTC, Steve Fanning
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Fanning 2020-03-19 13:20:57 UTC
Created attachment 158807 [details]
Example of IMPRODUCT function parameters problem

There is a problem with using the Function Wizard to create a call to the IMPRODUCT function.
(1) The Function Wizard provides for the input of 256 complex numbers.
(2) If you fill up these fields the function gives an error 512 (formula overflow).
(3) If you clear the 256th field, the function then gives an answer rather than an error.
See the attached spreadsheet for worked example.

So for this function, the Function Wizard UI is incorrect and should only provide for the input of 255 parameters.

It is possible that the same problem exists for the following functions:
- AGGREGATE
- GCD_EXCEL2003
- LCM_EXCEL2003
- MULTINOMIAL
- RAWSUBTRACT
- IMSUM
Comment 1 Commit Notification 2020-03-20 23:10:50 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d43d2662ff64c613740080e166d1046214edb0f0

Resolves: tdf#131423 Handle Function Wizard max argument count correctly

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 2 Eike Rathke 2020-03-30 14:11:59 UTC
Pending review https://gerrit.libreoffice.org/c/core/+/91300 for 6-4
Comment 3 Commit Notification 2020-04-23 09:23:03 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/a79bbe2f92f6a25b2e170f11a6aa2b6a5123fe2f

Resolves: tdf#131423 Handle Function Wizard max argument count correctly

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 BogdanB 2020-05-10 19:06:07 UTC
It's ok now. 255 fields. 

Verified on
Version: 7.0.0.0.alpha1
Build ID: 6a03b2a54143a9bc0c6d4c7f1...
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 5 Eike Rathke 2020-05-13 17:12:37 UTC
*** Bug 131657 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2020-05-29 16:40:50 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/92a87f9f128cf91f6af1fc7c61a85a10d659334d

Related: tdf#131423 CHOOSE() supports only 30 jump targets, limit in dialog

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-05-30 00:44:45 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/f92220b73d971e9d760c545efd60179ad1b6902a

Related: tdf#131423 CHOOSE() supports only 30 jump targets, limit in dialog

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.