Bug 131461 - Connexion to NextCloud and collaborative editing
Summary: Connexion to NextCloud and collaborative editing
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: CMIS
  Show dependency treegraph
 
Reported: 2020-03-21 11:48 UTC by Frederic Parrenin
Modified: 2022-04-06 08:24 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Parrenin 2020-03-21 11:48:59 UTC
I would like to connect the offline version of LO with NextCloud and to make use of the collaborative editing.
As far as I know, collaborative editing is only possible with LibreOffice Online.
Making use of the offline version for collaborative editing would allow to use all the rich features of the offline version.
Such kind of collaborative editing of the offline version is possible with Microsoft Office or OnlyOffive.
Comment 1 Frederic Parrenin 2020-04-05 09:21:40 UTC
I really meant connection to LibreOffice Online (or collabora Online), instead Nextcloud.
One more argument is that LOOL uses a lot of resource on the server side, since the rendering is all done there. Moreover, it uses a lot of bandwidth, since all the tiles are sent to the client at every key press.
The idea would be to render on the client, and to just exchange snippets of the ODF files between the client and the server every now and then.
The server would just be responsible for synchronizing the various clients and no more.
The rendering on the client would also be far more reactive than now.
I tried Collabora Online on the collabora demo server and was not really satisfied by the speed of rendering.
This idea has certainly been discussed already between the devs, but I cannot find an answer on the web why it has not been implemented this way.
Comment 2 Heiko Tietze 2022-04-06 08:24:06 UTC
You can open/save documents remotely per CMIS (File > Save Remote...). The dialog allows to configure a wide range of connections including WebDav to Nextcloud. And of course you may open files on NC with LibreOffice Online. 

Please reopen in case I missed the point.

https://help.libreoffice.org/latest/en-US/text/shared/guide/cmis-remote-files-setup.html
https://help.libreoffice.org/latest/en-US/text/shared/guide/digitalsign_receive.html