Bug 131478 - Enhancement request: Calc sticky setting for printing grids and/or click box in Tabbed bar
Summary: Enhancement request: Calc sticky setting for printing grids and/or click box ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Notebookbar-Tabbed
  Show dependency treegraph
 
Reported: 2020-03-22 14:32 UTC by Steve Horn
Modified: 2020-08-12 18:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Horn 2020-03-22 14:32:52 UTC
Description:
Too hard to find print grid option and it won't stick. 

Actual Results:
too hard to use

Expected Results:
easier to use


Reproducible: Always


User Profile Reset: No



Additional Info:
I'd love to pay for software that works. Libre Office works but is hard to use in many aspects.
Comment 1 ian 2020-03-22 20:18:04 UTC
Thank you for reporting the suggestion. 

As you noted in the title, this is an enhancement request; therefore, I have set the bug's severity to "enhancement."
Comment 2 eisa01 2020-05-02 17:42:55 UTC
Print document settings are saved on a per document basis as far as I can tell, so you only need to set this once.

I think that is the most sensible setting, as you may want different behavior for different documents?

This is the same as in MS Excel

What is slightly confusing is that this is set in the "Print Preview", which is rather "Print Preview and Settings"

But, you can switch to the new "tabbed bar" in View->User Interface which has the Ribbon style interface. Then the option is in the more sensible Layout tab under Page format. It is not as discoverable as MSO that have this as a checbox on the Page layout tab

I think this can be closed as not a bug, but I'll let the UX team decide

FYI: You are on a very old LO release, you should try to update to the latest 6.4.3
Comment 3 Steve Horn 2020-05-02 18:41:11 UTC
Thank you for your attention and reviewing this.

Regarding my version vs current: I get no notifications of new versions. I update all my software regularly and didn't know I was behind. Still, after update to 635 which was the latest I found, I don't see View/User Interface/Tabbed Bar, but any option there that I choose doesn't seem of offer any difference that I'm able to find. What I find regarding printing grid lines requires deep searching:

File/Print Preview/right-click/Format Page/Sheet/ . Who could possibly remember that.

In my (old version of Excel, the option to print gridlines is in the ribbon under layout. Two clicks max. Yes, this does save to document.


There is a lot to be proud of in Libre Office. But print grids is too hard to dig up, in my opinion.
Comment 4 eisa01 2020-05-02 18:52:49 UTC
I agree with you, the MS ribbon option of printing grid-lines seems to be a very sensible improvement to the Tabbed bar

Yes, there have been some bugs causing update checks to not function on older versions...

Make sure it's turned on in Preferences -> LibreOffice -> Online updates. Be aware that updates are rolled out slower here than online

The latest version is 6.4.3 or 6.3.6, so the 6.3.5 you downloaded is actually already old :)

https://www.libreoffice.org/download/download/

If you want a version that properly auto-updates properly you can purchase LibreOffice Vanilla from the App Store for $18 which goes toward making the macOS version better: https://apps.apple.com/app/libreoffice-vanilla/id921923693
Comment 5 Heiko Tietze 2020-05-14 07:18:21 UTC
No objection to the RFE so go for it.