Download it now!
Bug 131486 - LibreOffice Calc freezes itself and Gnome 3.36 on multiple cell select
Summary: LibreOffice Calc freezes itself and Gnome 3.36 on multiple cell select
Status: RESOLVED DUPLICATE of bug 121860
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.1.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-22 21:17 UTC by bughatter
Modified: 2020-06-19 03:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bughatter 2020-03-22 21:17:40 UTC
Description:
There is a high cost to selecting cells in Calc. It appears to linearly scale with the amount of cells already selected. I do not understand either of these facts.

Calc also is apparently not using the disk at this time.

Steps to Reproduce:
1. Open a new spreadsheet in LibreOffice Calc (within Arch Linux) (on Gnome 3.36).
2. Select n cells in different columns by left clicking while holding Ctrl. n is the number of cells such that selecting the n+1th cell takes at least 3 seconds. I estimate that n will be between 20 and 50 cells on your system.
3. Observe Calc using 100% of 1 CPU for several seconds. During this time you should not be able to do anything else on your system aside from observe the clock tick and an unclickable dialog box ask you if you wish to kill Calc do to its non-responsiveness.

Actual Results:
Calc spends millions of microseconds on the task of a single cell select when several cells are already selected.

Expected Results:
Calc spends at most 1 microsecond on the task of a single sell select regardless of how many cells are already selected:

Check if the cell is selected in memory. If it is, then select the cell. If not, then deselect the cell.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.1.2
Build ID: 6.4.1-3
CPU threads: 16; OS: Linux 5.5; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

I am using X11 and the official Nvidia Linux drivers.

Why does the length of time to select a cell depend on the number of cells already selected?

Why does your link on how to check if OpenGL is enabled wrong, because there is no option "Use OpenGL for all rendering" under the specified section of the settings?
Comment 1 Buovjaga 2020-06-18 18:51:03 UTC

*** This bug has been marked as a duplicate of bug 121860 ***