Download it now!
Bug 131522 - Unable to edit button control's Label in master after MLE => Edit control change
Summary: Unable to edit button control's Label in master after MLE => Edit control change
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Thorsten Behrens (allotropia)
URL:
Whiteboard: target:7.0.0 target:6.4.4 target:6.3....
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-03-24 08:03 UTC by Mike Kaganski
Modified: 2020-04-15 12:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2020-03-24 08:03:21 UTC
In a new document (both text and spreadsheet), insert a Push Button form control. In its Control Properties dialog, try to edit its Label

=> nothing changes

tested with Version: 7.0.0.0.alpha0+ (x64)
Build ID: 5feadfad0cc3be2680213d2e5f6f786b2f4cc74f
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: CL

OK in 6.4.2.2.
Comment 1 Xisco Faulí 2020-03-24 14:57:38 UTC Comment hidden (obsolete)
Comment 2 Xisco Faulí 2020-03-24 14:59:11 UTC
Reproduced in

Version: 7.0.0.0.alpha0+
Build ID: 9163755e9f64a0b1dd5f2090e0702c19e31c12c9
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

bisecting
Comment 3 Xisco Faulí 2020-03-24 15:05:39 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=1efeb17837c22499f00299c033ae59ba3910f7d7

author	Caolán McNamara <caolanm@redhat.com>	2019-11-04 13:06:04 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-12-09 13:28:35 +0100
commit	1efeb17837c22499f00299c033ae59ba3910f7d7 (patch)
tree	a8db0b758e942b3b14fba26129dc51a95ff5c10c
parent	4da3e0a0e5b2260c26186890724978bfd00f796c (diff)
weld Property Browser

Bisected with: bibisect-linux64-6.5

Adding Cc: to Caolán McNamara
Comment 4 Xisco Faulí 2020-03-24 15:07:04 UTC
also reproducible with gtk3
Comment 5 Commit Notification 2020-03-25 14:24:22 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5bb908656475ed982bd7d63447df8e740171c6e3

Resolves: tdf#131522 sync textview from edit when edit changes

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Thorsten Behrens (allotropia) 2020-03-27 00:47:20 UTC
Looks like fix for bug 131000 broke that for 6.3 and 6.4, too?
Comment 7 Caolán McNamara 2020-03-27 09:26:03 UTC
and what does that have to do with me ?
Comment 8 Thorsten Behrens (allotropia) 2020-03-27 10:21:09 UTC
(In reply to Caolán McNamara from comment #7)
> and what does that have to do with me ?

Nothing? ;)
Comment 9 Thorsten Behrens (allotropia) 2020-03-27 10:38:25 UTC
https://gerrit.libreoffice.org/c/core/+/91186
Comment 10 Commit Notification 2020-03-27 10:41:25 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/7cf70cffc305fc6c470f7230a897d6c70b18ffad

tdf#131522 get notified when user edits in OMultilineEditControl

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2020-03-27 13:16:23 UTC
(In reply to Thorsten Behrens (CIB) from comment #9)
> https://gerrit.libreoffice.org/c/core/+/91186

Verified in

Version: 6.4.4.0.0+
Build ID: 4f8325dbcb63627997289889a377a4893e03fcf1
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Thorsten, thanks for spotting and fixing the issue in Libo 6.4 & 6.3
Comment 12 Commit Notification 2020-03-27 16:17:01 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/748d0fb49c9dcd559ad9e590390bcf1c9005b203

tdf#131522 get notified when user edits in OMultilineEditControl

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2020-04-07 15:21:17 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-3":

https://git.libreoffice.org/core/commit/a116f3ef7d159569f7059079c0d1b1707429cbac

tdf#131522 get notified when user edits in OMultilineEditControl

It will be available in 6.4.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Xisco Faulí 2020-04-15 12:12:52 UTC
Setting to VERIFIED based on comment 11