Bug 131592 - libreoffice-base not installed and mail merge wizard fail to install it automatically, all database functionalities not working
Summary: libreoffice-base not installed and mail merge wizard fail to install it autom...
Status: RESOLVED DUPLICATE of bug 75369
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-26 07:22 UTC by libreoffice
Modified: 2020-04-16 07:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
mail merge wizard requesting to restart, can be confusing (12.38 KB, image/png)
2020-03-26 07:23 UTC, libreoffice
Details
system popup requesting software installation on xubuntu 18.04 (14.76 KB, image/png)
2020-03-26 07:24 UTC, libreoffice
Details
gnome-software failing to find libreoffice-base package (16.24 KB, image/png)
2020-03-26 07:25 UTC, libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description libreoffice 2020-03-26 07:22:42 UTC
Description:
Hi,

I'm trying to follow a exercise using mail merge wizard, or database related functionality like: Insert > Field > More Field : tab Database > Add database file ...

Obviously the database functionality are missing as the Linux package libreoffice-base is missing. 

The Tools > Mail merge wizard... display a window asking to restart LibreOffice. 
At the same time a system popup ask to install additional software. But clicking the visual interface fail.

Adding the package from command line works:

sudo apt install libreoffice-base
 
For normal user this behavior may be not trivial.

LibreOffice should informs more explicitly the user, that the package libreoffice-base is missing and that all functionalities involving database are currently disabled.

See also attached screenshot.

done on Xubuntu 18.04 

Steps to Reproduce:
1. Open LibreOffice Writer
2. Tools > Mail merge wizard... 
3. Click on the system popup (gnome-software) "Find in Software" button

Actual Results:
gnome-software fail to find "libreoffice-base" package. 

The package's name "libreoffice-base" could be ambiguous for helping user to find what is missing. As the message is: 

"Unfortunately, the libreoffice-base you were searching for could not be found. Please see this website for more information."

The link is pointing to: https://help.ubuntu.com/community/Repositories/

Also, using a different approach on Writer to access the database options are allowed but don't do anything. So user becomes frustrated as it doesn't work but  doesn't complain about the missing database software:

Insert > Field > More Field : tab Database > Add database file ...

You can select and add the spreadsheet file, but nothing happen.

Expected Results:
All tentative to access database fields should warn the user that some software component are missing, instead of silently fail.

The message from mail merge wizard should be more explicit to the user, than an external software will be installed and could offer a link to the documentation or FAQ to help, in the case where the software management tools fail to install the package.

Also, the automatic installation should work as the package "libreoffice-base" is present and sudo apt install libreoffice-base works.

Of course this last bug may be part of the gnome-software itself. 


Reproducible: Always


User Profile Reset: No



Additional Info:
Writer
Version: 6.0.7.3
Build ID: 1:6.0.7-0ubuntu0.18.04.10
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: fr-FR (en_US.UTF-8); Calc: group

lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 18.04.4 LTS
Release:	18.04
Codename:	bionic

uname -a
Linux lap42 4.15.0-91-generic #92-Ubuntu SMP Fri Feb 28 11:09:48 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
OpenGL core profile version string: 4.2 (Core Profile) Mesa 19.2.8
OpenGL core profile shading language version string: 4.20
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 19.2.8
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 19.2.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:
Comment 1 libreoffice 2020-03-26 07:23:55 UTC
Created attachment 159023 [details]
mail merge wizard requesting to restart, can be confusing
Comment 2 libreoffice 2020-03-26 07:24:51 UTC
Created attachment 159025 [details]
system popup requesting software installation on xubuntu 18.04
Comment 3 libreoffice 2020-03-26 07:25:32 UTC
Created attachment 159026 [details]
gnome-software failing to find libreoffice-base package
Comment 4 Alex Thurgood 2020-04-15 13:25:28 UTC
This not our bug, but Ubuntu's decision not to install the Base components (including any DB drivers) by default.


If Ubuntu (Canonical) want to correct the error message to highlight their failure to include the Base packages by default, surely, that is up to them.

You could always try opening up a corresponding bug report in the Ubuntu Launchpad, but probably won't lead anywhere:

https://askubuntu.com/questions/453728/libreoffice-base-not-opening-in-14-04
Comment 5 Alex Thurgood 2020-04-15 13:28:57 UTC
Even better, found the duplicate from 2014...

*** This bug has been marked as a duplicate of bug 75369 ***
Comment 6 Adolfo Jayme 2020-04-15 22:39:18 UTC
> If Ubuntu (Canonical) want to correct the error message to highlight their
> failure

Please save the FUD to yourself.
Comment 7 Alex Thurgood 2020-04-16 07:13:54 UTC
(In reply to Adolfo Jayme from comment #6)
> > If Ubuntu (Canonical) want to correct the error message to highlight their
> > failure
> 
> Please save the FUD to yourself.

No fear, uncertainty or doubt about it. This was clearly a decision taken by someone at some stage within Canonical when it came to including LO in the release.

The fact that is has an effect on user's of Canonical's Ubuntu distribution and is an ongoing topic repeatedly reported on both the LO bugzilla and on LibreOffice Ask clearly shows that it has an impact on those users (I should know, I am one of them). It shows LibreOffice in a bad light, but it wasn't a LibreOffice project decision.