Bug 131633 - Referencing formula cannot be copied to a new ods file
Summary: Referencing formula cannot be copied to a new ods file
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-External-Datalink
  Show dependency treegraph
 
Reported: 2020-03-27 17:27 UTC by omui+libreoffice
Modified: 2022-06-17 03:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description omui+libreoffice 2020-03-27 17:27:04 UTC
Description:
On Linux, when I tried to copy formula that reference a cell on an external, local ods file to a new ods file, the formula will be lost.




Steps to Reproduce:
1. Create 3 ods files: 1.ods, 2.ods and 3.ods

2. On 1.ods, enter A1=1, A2=2

3. On 2.ods, reference values from 1.ods, such that:

A1 of 2.ods = A1 from 1.ods
A2 of 2.ods = A2 from 1.ods

Such that:
A1='file:///local.directory/1.ods'#$Sheet1.A1
A2='file:///local.directory/1.ods'#$Sheet1.A2

, where "file:///local.directory/1.ods" is the location of 1.ods


4. Try copying A1 and A2 from 2.ods to 3.ods, either with Ctrl+C and V or from the menu.

Actual Results:
On 3.ods, each copied cell will have a "#NAME?" error, and each cell only has "=" inside. 


Expected Results:
On 3.ods, the referencing formula are copied over, where

A1='file:///local.directory/1.ods'#$Sheet1.A1
A2='file:///local.directory/1.ods'#$Sheet1.A2




Reproducible: Always


User Profile Reset: Yes



Additional Info:
It appears that the external link (to 1.ods) is not copied over.

During paste, if I select "Paste Special" and check "Link", then an array will be copied. However, with arrays, each cell cannot be individually modified.
Comment 1 Bhavesh Patel 2020-03-27 19:56:15 UTC
"Paste special" and selecting "Link" option, copies an array. The workaround I found, if you want to edit a single cell, is to copy each cell individually. The program still copies it as a single cell array but when I try to modify this single cell array in the formula bar, Calc lets me modify it just like any other formula.

Selecting multiple cells at once and copying all of them as a single array makes them un-editable.
Comment 2 Buovjaga 2020-06-16 17:25:31 UTC
Reproduced. In version 3.3.0 the result is in the style:
=''#$Sheet1.A1

I tried very hard to find an existing report, but could not find one. Somehow I suspect there should be one as this is so old.

Arch Linux 64-bit
Version: 7.1.0.0.alpha0+
Build ID: 43bdac0ebd65dfc32a0b8cf2c42fde88ad585e3f
CPU threads: 8; OS: Linux 5.7; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 15 June 2020
Comment 3 QA Administrators 2022-06-17 03:32:54 UTC
Dear omui+libreoffice,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://web.libera.chat/?settings=#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug