Bug 131658 - "Insert Caption" results in an invisible space at start of line: typed input disabled at this location
Summary: "Insert Caption" results in an invisible space at start of line: typed input ...
Status: RESOLVED DUPLICATE of bug 123801
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Caption
  Show dependency treegraph
 
Reported: 2020-03-29 11:21 UTC by R. Green
Modified: 2022-04-28 11:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Writer file showing image plus caption (259.03 KB, application/vnd.oasis.opendocument.text)
2020-03-29 11:21 UTC, R. Green
Details

Note You need to log in before you can comment on or make changes to this bug.
Description R. Green 2020-03-29 11:21:05 UTC
Created attachment 159115 [details]
Writer file showing image plus caption

Version: 6.4.1.2 (x64)
Build ID: 4d224e95b98b138af42a64d84056446d09082932
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-GB
Calc: threaded

1. Open the attached writer file.
2. Try to enter a character at the beginning of the caption.

RESULT: Keyboard is apparently disabled. Anything to do with Bug 131302?
Comment 1 Telesto 2020-03-29 18:14:17 UTC
Repro with
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 7ae9c9572ccac55c0926b8a9779bb63c4236291c
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL

and with
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL

Not 100% sure if it's a bug or not; setting to new anyway
Comment 2 R. Green 2020-03-30 10:38:21 UTC
On further investigation, it is possible to duplicate this bug from scratch:

1. New Document.
2. Insert > Image (chose a .png, say).
3. Right click on image. Chose "Insert caption". Write, say, "This is a caption" and set "Category" to "None."
4. Put cursor at beginning of caption line and try to type something.

RESULT: Nothing happens.
Comment 3 R. Green 2020-04-02 12:50:12 UTC
On further investigation it appears that there is an extra invisible character at the start of the line.

1. Repeat steps 1-3, above.
4. Set "Caption" style alignment to "Centre" (this allows you to see the problem more clearly).
5. Put cursor before first letter in caption and press [Shift] + [left arrow].

EXPECTED RESULT: No selection.
ACTUAL RESULT: A spurious space character is selected.

If you now delete this space, you can now type text before the first letter of the caption as expected.
Comment 4 QA Administrators 2022-04-08 04:20:58 UTC Comment hidden (obsolete)
Comment 5 Gabor Kelemen (allotropia) 2022-04-28 11:03:19 UTC
The hidden line break character was reverted when solving bug 123801 - now (i.e. since 7.0) if you add a caption to an image, there is no hidden character at the beginning and you can type in front of the caption.

*** This bug has been marked as a duplicate of bug 123801 ***