Bug 131687 - Windows open in wrong display when used both through ssh and locally by the same user
Summary: Windows open in wrong display when used both through ssh and locally by the s...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Network
  Show dependency treegraph
 
Reported: 2020-03-29 21:59 UTC by fabien.perdu
Modified: 2022-05-23 18:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fabien.perdu 2020-03-29 21:59:00 UTC
Description:
If a same user of a given host has a libreoffice window opened via ssh, and then tries to open another windows locally, then the new window does not open locally but on the distant display.

Steps to Reproduce:
1. From host2, login via ssh into host1 :
ssh -X user@host1
2. Launch a libreoffice window : lowriter (or localc, or...)
3. Get off your seat, change room, go to host1.
4. Working locally on host1 as the same user, try to launch a libreoffice window : lowriter (or localc, or...)

Actual Results:
No window opens in host1.
However, if you change seat again and go to host2, your new window is there...

Expected Results:
The new window should open locally


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 5.1.6.2
Build ID: 1:5.1.6~rc2-0ubuntu1~xenial10
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: fr-FR (en_US.UTF-8); Calc: group
Comment 1 ian 2020-04-15 13:46:30 UTC Comment hidden (obsolete)
Comment 2 fabien.perdu 2020-05-09 19:56:08 UTC
host1 has been upgraded to Ubuntu 20.04 LTS
Therefore libreoffice on host 1 is now the following :

Version: 6.4.3.2
Build ID: 1:6.4.3-0ubuntu0.20.04.1
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: fr-FR (en_US.UTF-8); UI-Language: en-US

The behaviour has not changed.
Comment 3 Timur 2020-08-28 06:32:52 UTC
Rule of thumb is search before reporting and confirming. 
Looks like a duplicate, I mark so. 
If you disagree, write details and reasons and set Unconfirmed.

*** This bug has been marked as a duplicate of bug 120903 ***
Comment 4 fabien.perdu 2020-08-28 07:24:04 UTC
I may not understand anything but it doesn't look like the same bug for me :
in my case I have problem with different X displays, one being tunneled via SSH, and the main window is opening on the wrong display.

In the case of Bug 120903, the question is about -dialog- windows opening in another -screen- (not display) as the main window.

It may be the same bug having these two consequences, but until it is found and corrected that does not seem obvious at all to me...
Comment 5 Xisco Faulí 2021-11-23 10:52:11 UTC
Hello Fabien,
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 6 QA Administrators 2022-05-23 03:38:32 UTC Comment hidden (obsolete)
Comment 7 Timur 2022-05-23 12:26:15 UTC
I reproduced this with LO 7.2. It's not about the version.
Based on explanation in bug 141960, I mark this NotABug.
If you disagree feel free to explain why this case would be different. 
Missing here in the report was use case, what for Expected behavior would be used.
Comment 8 Timur 2022-05-23 18:30:06 UTC
gedit works the same.