Download it now!
Bug 131767 - Crash when opening mail merge wizard for attached doc
Summary: Crash when opening mail merge wizard for attached doc
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0 target:6.4.3
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2020-04-01 09:22 UTC by Michael Weghorn
Modified: 2020-04-04 04:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample doc to reproduce crash (49.50 KB, application/msword)
2020-04-01 09:22 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weghorn 2020-04-01 09:22:40 UTC
Created attachment 159211 [details]
sample doc to reproduce crash

Trying to open the mail merge wizard for the attached document crashes LibreOffice

Steps to reproduce:

1) open attached document "Vereine_Muster_Geldzuwendung.doc"
2) "Tools" -> "Mail Merge Wizard..."

-> crash

Version: 7.0.0.0.alpha0+
Build ID: aa24771563425072c710e8c426323ed311437f13
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: en-US (en_GB.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Michael Weghorn 2020-04-01 09:24:05 UTC
It's a regression, bibisected to the following commit:

commit 693d9ff29e7838bafcad5faa7a4e7355807c54cb
Author: Caolán McNamara <caolanm@redhat.com>
Date:   Thu Aug 22 09:15:51 2019 +0100

    weld SwMailMergeWizard
    
    Change-Id: I03a7fd1f7676792387155db986d710a001887c8d
    Reviewed-on: https://gerrit.libreoffice.org/77977
    Tested-by: Jenkins
    Reviewed-by: Caolán McNamara <caolanm@redhat.com>
    Tested-by: Caolán McNamara <caolanm@redhat.com>

-> Adding Caolán in CC
Comment 2 Xisco Faulí 2020-04-01 09:55:35 UTC
I can't reproduce it in

Version: 7.0.0.0.alpha0+
Build ID: 169a10f0e4680814145b668c6320be04038d7a89
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Caolán McNamara 2020-04-01 11:09:46 UTC
there seems to be an exception throw by xStore->storeToURL( m_sExampleURL called by mmlayoutpage.cxx
Comment 4 Caolán McNamara 2020-04-01 11:13:55 UTC
oddly, opening from the command line and I get the problem, but opening from the recently used start center and I don't
Comment 5 Caolán McNamara 2020-04-01 13:27:11 UTC
ah.., its not a full regression, in older versions it will crash the same way on reaching adjust layout
Comment 6 Commit Notification 2020-04-01 14:35:30 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/960c12bc7e64f70288385545a1555cebf315d534

Resolves: tdf#131767 explicitly get the odt filter

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-04-01 15:13:58 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c95db2f6a088de12012b88fa8505ae42b0cc90c7

Related: tdf#131767 explicitly get the odt filter

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2020-04-01 15:14:39 UTC
that seems to work for me, fixed in master backport to 6-4 in gerrit
Comment 9 Commit Notification 2020-04-02 05:22:16 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/fdc768a10024998f6ed27991ea722645b3f5c246

Resolves: tdf#131767 explicitly get the odt filter

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Michael Weghorn 2020-04-02 05:23:08 UTC
Thanks, Caolán!

Fix verified with

Version: 7.0.0.0.alpha0+
Build ID: 3ea506eb7a0b11323569956255475dfbb113a6a5
CPU threads: 64; OS: Linux 4.9; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded
Comment 11 Commit Notification 2020-04-02 10:58:43 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-3":

https://git.libreoffice.org/core/commit/708f8c4dfcf29550e5f69cb09add76403a4eefa8

Resolves: tdf#131767 explicitly get the odt filter

It will be available in 6.4.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.