Bug 131847 - Save document window place and size inside document
Summary: Save document window place and size inside document
Status: RESOLVED DUPLICATE of bug 38062
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-03 09:14 UTC by Pikki
Modified: 2020-08-30 19:49 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pikki 2020-04-03 09:14:09 UTC
Description:
When opening an existing document, Libre Office uses the window place and size that was used for previous document of same type (calc, write, ...).

Working with different size documents, like smalls calc sheets that must display together and other very large document is boring : you must resize and move windows at each opening.

It would be very nice to have the document position and size saved inside the the document file itself, eventually as an option "Include windows place and size".

When opening the document, there will be 2 cases :
 1) the document windows position is defined inside the document file AND the saved place and size can fit entirely in the screen : display it at defined place,
 2) if windows position & size are not defined, or if they overlap some border of the screen, display the windows at default size like actually, or with position and size adjusted to fit in screen.


Steps to Reproduce:
1. Open two calc documents A and B, move them to be able to work on them together without overlap. Save them both and close them.
2. Open a single very large calc document C, save and close it.
3. Reopen the two documents A and B.

Actual Results:
The two documents A and B are opened with windows position and size of document C. You must resize them both and move the two windows to retrieve their position and to be able to work on them together.

Expected Results:
A and B document reopens at the place and size that they at last save. 
and later, C document would also reopen at its place and size.


Reproducible: Always


User Profile Reset: No



Additional Info:
It is interesting to also save "Windows Maximized" (WM_MAXIMIZE) state, and restaure it at document opening, along to windows place and size that will be used to un-maximize (restaure) the document windows.
Comment 1 Pikki 2020-05-20 22:51:34 UTC
Hi,

I Apologize for the question here, but what means "QA:needsComment" ?
Comment 2 Buovjaga 2020-08-30 19:49:42 UTC

*** This bug has been marked as a duplicate of bug 38062 ***