Download it now!
Bug 131942 - UI: No progress bar saving in Calc
Summary: UI: No progress bar saving in Calc
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All Windows (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0 target:7.0.0.1 target:7....
Keywords: bibisected, bisected, regression
Depends on:
Blocks: File-Progress-Bar
  Show dependency treegraph
 
Reported: 2020-04-06 21:12 UTC by Telesto
Modified: 2020-07-04 11:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
progressbar in Libo 7.0 alpha1 (133.72 KB, image/png)
2020-05-11 14:12 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-04-06 21:12:35 UTC
Description:
No progress bar saving in Calc

Steps to Reproduce:
1. Open attachment 159372 [details]
2. Press Save

Actual Results:
No progress bar

Expected Results:
Progress bar


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 4501a0ba623ad61c5a4e0b807da2e96f0e4ce82c
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 ian 2020-04-07 13:44:19 UTC
Thank you for reporting the bug.

I have set the severity of the bug to "trivial," since this is a GUI issue.
Comment 2 Xisco Faulí 2020-05-11 14:12:08 UTC
Not reproduced in

Version: 7.0.0.0.alpha1+
Build ID: 86bc13248c1d9f63b10aac304bdf0361d1dcc47f
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Telesto, could you please try with the latest daily build?
Comment 3 Xisco Faulí 2020-05-11 14:12:35 UTC
Created attachment 160668 [details]
progressbar in Libo 7.0 alpha1
Comment 4 Telesto 2020-05-11 14:42:24 UTC
Still nothing
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 97a2c1fc5e376c0c00968f17a0392c6d3a5ed565
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: threaded
Comment 5 Xisco Faulí 2020-05-11 14:44:49 UTC
what about older versions ? maybe it WIN only
Comment 6 Telesto 2020-05-11 14:48:11 UTC
Fine with
Version: 6.0.6.0.0+
Build ID: c30963b8b4bbbe42a24b97aafa161eff9d7ccdd4
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc:
Comment 7 ian 2020-05-12 13:17:27 UTC
I reproduced it in Windows:

Version: 7.0.0.0.alpha1 (x64)
Build ID: 6a03b2a54143a9bc0c6d4c7f1...
CPU threads: 2; OS: Windows 10.0 Build 17763; UI render: Skia/Raster; VCL: win; 
Locale: en-US (en_US); UI: en-US
Calc: threaded

No visible progress bar.
Comment 8 Buovjaga 2020-06-10 19:50:22 UTC
Bibisected with Win 6.5 repo to https://git.libreoffice.org/core/+/a7de363cead5cd0021d2e3df4573d4cbe27df23b%5E!/
remove unnecessary Window::Update() calls, which immediately follow Invalidate

Adding Cc: to Noel Grandin

For the testing, I cut down the document to smaller size so it would not take so long to save, but still be useful in indicating good/bad.
Comment 9 b. 2020-06-11 04:09:30 UTC
some seconds nothing and then a short flicking up nearly full bar ... 

Version: 7.1.0.0.alpha0+
Build ID: 20ba8d8d9f4fcf7d5826fcb3366a9bff0d6a8ca1
CPU threads: 8; OS: Linux 5.6; UI render: default; VCL: gtk3
Locale: en-US (en_US.utf8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-06-10_07:16:41
Calc: threaded
Comment 10 Buovjaga 2020-06-11 07:25:28 UTC
(In reply to b. from comment #9)
> some seconds nothing and then a short flicking up nearly full bar ... 
> 
> Version: 7.1.0.0.alpha0+
> Build ID: 20ba8d8d9f4fcf7d5826fcb3366a9bff0d6a8ca1
> CPU threads: 8; OS: Linux 5.6; UI render: default; VCL: gtk3
> Locale: en-US (en_US.utf8); UI: en-US
> TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
> 2020-06-10_07:16:41
> Calc: threaded

This is the "not reproduced" scenario. If you reproduce the problem, you will see no progress bar whatsoever.
Comment 11 Commit Notification 2020-06-13 19:51:14 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fc617677dedc2ee6f52149bac71195420bc351f3

tdf#131942 no progress bar when saving in calc

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-06-16 09:24:21 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/33f3f50bd507bd2a2fa6efdfe935be5b7d648f3b

tdf#131942 no progress bar when saving in calc

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Buovjaga 2020-06-16 19:17:13 UTC
Telesto: now we got new Win builds, but I still get the issue of no progress bar - can you test? I repro with or without Skia.

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 33a720ab802491f15b247e09755cd36205b6f435
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: Skia/Raster; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded
Comment 14 Telesto 2020-06-16 19:55:39 UTC
Save.. nothing nothing nothing.. nearly full bar, finish

Version: 7.1.0.0.alpha0+ (x64)
Build ID: a35c18aeff3b1d8f270db7e094850fb8ba1ab84a
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 15 Xisco Faulí 2020-06-17 08:46:17 UTC
Let's reopen it then. Thanks for doublechecking
Comment 16 Noel Grandin 2020-07-02 06:52:12 UTC
I built the version before the indicated commit (on Linux) and I still see the same effect (i.e. no proper progress bar).

Could someone re-do the bibisect please?
Comment 17 Buovjaga 2020-07-02 08:02:58 UTC
(In reply to Noel Grandin from comment #16)
> I built the version before the indicated commit (on Linux) and I still see
> the same effect (i.e. no proper progress bar).
> 
> Could someone re-do the bibisect please?

Hmm, interesting, because Xisco did not see the problem on Linux, so we treated this as a Win-only issue. Now I tried with master and at least with GTK3 backend there is a progress bar shown for a few seconds. Which backend did you use, Noel?
Comment 18 Noel Grandin 2020-07-02 08:05:14 UTC
Ah, my apologies, I did not notice that was Windows only. I was testing with the gtk3 backend.

I will debug again on Windows.
Comment 19 Commit Notification 2020-07-03 13:41:25 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/23e8739b98e1fff3be70159182b20642b70122de

tdf#131942 no progress bar saving in Calc

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2020-07-03 20:00:35 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/dccb00809e4d16abf2cf2176151fedaee209e4c6

tdf#131942 no progress bar saving in Calc

It will be available in 7.0.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Buovjaga 2020-07-04 11:53:46 UTC
I've never been so happy to see a progress bar in my life!

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 92c2318db92c3f102243ef1f8a9a492796932ff6
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: Skia/Raster; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded