Download it now!
Bug 132038 - Image rotation angle (inserting a value or by pressing plus or minus) not working [GTK3 only]
Summary: Image rotation angle (inserting a value or by pressing plus or minus) not wor...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0 target:6.3.6 target:6.4.4
Keywords:
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2020-04-10 19:59 UTC by BogdanB
Modified: 2020-04-14 21:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
video of the bug (683.23 KB, video/mp4)
2020-04-11 15:45 UTC, BogdanB
Details
gtk vs. gen (2.34 MB, video/mp4)
2020-04-11 20:57 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description BogdanB 2020-04-10 19:59:29 UTC
Description:
Insert any image in a new Writer document. Right click. Properties. Go to tab IMAGE. And here try to insert another angle, or to press plus or minus.

Steps to Reproduce:
1. New Writer document. Insert any image
2. Right click and go to tab IMAGE
3. Try to change the angle (the number) or to press + - sign.

Actual Results:
Nothing happend.

Expected Results:
The image should rotate, and the number should be inserted.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.4.2.2
Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 BogdanB 2020-04-10 20:00:57 UTC
Also not working in
Version: 6.3.4.2
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 2 Ming Hua 2020-04-11 09:00:51 UTC
I'm not sure I understand this bug report.  With my LO 6.3.5 on Windows 10, the inserted image rotates as specified after I click the "OK" button.

Do you mean that there is no real-time rotation when you change the angle either by inputting a number or pressing the +/- buttons?
Comment 3 BogdanB 2020-04-11 15:45:43 UTC
Created attachment 159489 [details]
video of the bug

Yes, not real time update. But not update at all... See the video
Comment 4 Ming Hua 2020-04-11 16:26:31 UTC
(In reply to BogdanB from comment #3)
> Yes, not real time update. But not update at all... See the video
I see, I don't have this problem on Windows.

Can you try setting the environment variable SAL_USE_VCLPLUGIN to gen, like
$ SAL_USE_VCLPLUGIN=gen libreoffice
to force LO to use X11 instead of GTK3, and see if it changes anything?
Comment 5 BogdanB 2020-04-11 18:05:24 UTC
I tried this commends in a terminal, but I get this:

SAL_USE_VCLPLUGIN=gen libreoffice
Command 'libreoffice' not found, but can be installed with:
sudo snap install libreoffice         # version 6.4.2.2, or
sudo apt  install libreoffice-common
See 'snap info libreoffice' for additional versions.

How can I change the other way LO to use X11 instead of GTK3?
Comment 6 BogdanB 2020-04-11 18:08:17 UTC
I have to mention that I install LO from .deb packages, from terminal.
Comment 7 BogdanB 2020-04-11 18:26:24 UTC
I succeded:

Version: 7.0.0.0.alpha0+
Build ID: 0dd48d1a9a716456ff1ebe67e19881ad2f56939b
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: x11; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-03-31_14:07:24
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded

LO now looks awfull, but that options work.

In this case this is not a bug?...
Comment 8 Ming Hua 2020-04-11 20:11:20 UTC
(In reply to BogdanB from comment #7)
> I succeded:
> 
> Version: 7.0.0.0.alpha0+
> Build ID: 0dd48d1a9a716456ff1ebe67e19881ad2f56939b
> CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: x11; 
> TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
> 2020-03-31_14:07:24
> Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> LO now looks awfull, but that options work.
> 
> In this case this is not a bug?...
It still is a bug, this is just helping us to find the most suitable developer to look into this bug.

It would still be nice if you can test with version 6.3.4 and 6.4.2 mentioned earlier, instead of this daily-build version.  I haven't used Debian/Ubuntu for a few years and can't remember the way to find the command-line name of the installed program, I'll try to look it up.
Comment 9 Ming Hua 2020-04-11 20:23:28 UTC
If you remember the .deb package names (e.g. if you downloaded them from LO official website, you can always download again and look at the package names), use
$ dpkg-query --listfiles [package_name]

If you don't remember the package names, try
$ dpkg-query --search lowriter
or
$ dpkg-query --search swriter

You should find the exact file name of the LO program.  Then you can start version 6.3.4 or 6.4.2 without GTK3:
$ SAL_USE_VCLPLUGIN=gen [full_program_name_with_path]

If you are still stuck, go to Debian/Ubuntu help channel and ask how to identify the program path and name for LO.
Comment 10 BogdanB 2020-04-11 20:52:39 UTC
I tested on 6.3.4.2. With X11 working, with GTK not.
Comment 11 BogdanB 2020-04-11 20:57:16 UTC
Created attachment 159496 [details]
gtk vs. gen

I have created a video with GTK and X11 to see the tests.
Comment 12 Ming Hua 2020-04-11 21:22:20 UTC
Thanks for testing.  Now let's ping the GTK3 meta bug and see what the experts there says.
Comment 13 Commit Notification 2020-04-12 15:22:11 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/15ff451d4a1de46da8f949ee0e1e402bda845568

Resolves: tdf#132038 missing adjustment for rotation

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Caolán McNamara 2020-04-12 15:22:59 UTC
fixed in master, backport to 6-4 and 6-3 in gerrit
Comment 15 Commit Notification 2020-04-12 16:30:04 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/5a2d42cab6b95c9fc4bc1ce86d740f35e37ae0a1

Resolves: tdf#132038 missing adjustment for rotation

It will be available in 6.3.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2020-04-12 16:30:17 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/d37dbb0375d28287d9c48638b65fdf437751b00c

Resolves: tdf#132038 missing adjustment for rotation

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Xisco Faulí 2020-04-14 18:59:42 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: 35fc5ef0a759884b24ed8b83cd05702a0fab64cc
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!
Comment 18 Commit Notification 2020-04-14 19:07:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3-6":

https://git.libreoffice.org/core/commit/8c79a3caa41c233e2a716d9f5bbfe2652d389452

Resolves: tdf#132038 missing adjustment for rotation

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.