Bug 132056 - FORMATTING: Change cursor to indicate whole line is selectable
Summary: FORMATTING: Change cursor to indicate whole line is selectable
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
: 145352 (view as bug list)
Depends on:
Blocks: Selection
  Show dependency treegraph
 
Reported: 2020-04-11 23:37 UTC by bobmcg
Modified: 2021-11-08 09:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bobmcg 2020-04-11 23:37:08 UTC
Description:
When the cursor is outside the left margin and aligned with a text line, change the cursor to a slanted arrow and allow selecting of the entire line with a mouse click.  See this feature in MS Word for guidance.

Actual Results:
n/a

Expected Results:
n/a


Reproducible: Always


User Profile Reset: No



Additional Info:
n/a
Comment 1 Dieter 2020-04-14 08:27:08 UTC
I don't see the use case. If cursor is outside the left margin you can select
- a word (two clicks)
- a sentence (three clicks)
- a paragraph (four clicks)

Use cases will be very seldom, where you select a line, that is not a sentence or a paragraph.

Wpuld be helpful, if you can give some examples in a document.

cc: Design-Team for further input and decision
Comment 2 Heiko Tietze 2020-04-14 09:11:54 UTC
As Dieter said, WF. It's not just the cursor also the behavior would have to change. The rightwards pointing arrow is true for table, however. Please reopen if we misunderstood your request, Bob.
Comment 3 V Stuart Foote 2020-04-14 12:51:59 UTC
agree => WF
Comment 4 Heiko Tietze 2021-11-08 09:28:33 UTC
*** Bug 145352 has been marked as a duplicate of this bug. ***