Bug 132548 - PDF: export gets wrong modification date in Samba share
Summary: PDF: export gets wrong modification date in Samba share
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Network
  Show dependency treegraph
 
Reported: 2020-04-30 09:19 UTC by HansPL
Modified: 2020-12-16 03:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A document with such a field. (8.73 KB, application/vnd.oasis.opendocument.text)
2020-04-30 09:42 UTC, HansPL
Details

Note You need to log in before you can comment on or make changes to this bug.
Description HansPL 2020-04-30 09:19:56 UTC
Description:
When exporting an ODT text document to PDF, data fields with the modification date are exported showing the current date instead of the correct modification date.  

Steps to Reproduce:
1. Create a text document with a data field Document Info: Modified; save it. (Option “Printing sets Document modified” is disabled.)  
2. Wait a day (or fiddle with your system’s date). 
3. Open it again:  the data field shows the old date of saving. 
4. Export it to PDF:  the PDF shows the current date *WRONG* 
5. LO still shows the old date of saving. 
6. Print to an printer:  the printout shows the old date of saving. *CORRECT*
7. Close the document:  LO asks to save it although option “Printing sets Document modified” is disabled.  

Actual Results:
The PDF shows the current date *WRONG* 

Expected Results:
The PDF should show the modification date (of last saving).  


Reproducible: Always


User Profile Reset: No



Additional Info:
A workaround seems to be to open the document read-only for exporting.
Comment 1 HansPL 2020-04-30 09:42:42 UTC
Created attachment 160117 [details]
A document with such a field.
Comment 2 HansPL 2020-04-30 09:44:33 UTC
On further experimenting:  this seems to happen when the ODT resides on a Samba share, where an older PDF already exists to be overwritten or I enter a different name for the export.
Comment 3 Justin L 2020-12-15 13:00:32 UTC
It must be under pretty unique circumstances, because anytime I save/export your document - including to a mounted samba folder - the date remains April 28.

I'm going to mark it as works for me. If you come up with clear steps to reproduce and want to re-open - that's fine.