Bug 132569 - Empty export from Writer to PDF in Lubuntu with QT5
Summary: Empty export from Writer to PDF in Lubuntu with QT5
Status: RESOLVED DUPLICATE of bug 125234
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.4.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Qt5
  Show dependency treegraph
 
Reported: 2020-05-01 07:04 UTC by max
Modified: 2020-05-04 20:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
exported PDF (1.26 KB, application/pdf)
2020-05-01 07:06 UTC, max
Details
text file (8.05 KB, application/vnd.oasis.opendocument.text)
2020-05-01 09:58 UTC, max
Details
testLO64fe.pdf (10.11 KB, application/pdf)
2020-05-01 16:24 UTC, Bart
Details
FirefoxTestLO64fe.png (92.43 KB, image/png)
2020-05-01 16:25 UTC, Bart
Details
KonquerorTestLO64fe.png (38.83 KB, image/png)
2020-05-01 16:25 UTC, Bart
Details
FileExportAsPDF.png (81.85 KB, image/png)
2020-05-01 16:26 UTC, Bart
Details

Note You need to log in before you can comment on or make changes to this bug.
Description max 2020-05-01 07:04:40 UTC
Description:
A text with Latin and Cyrillic symbols. The former are not visible, the latter exports as question marks. Resulted file, when opened in Firefox, give a warning about possibility of content being not displayed correctly.

Steps to Reproduce:
1.create new doc
2.type any sentence
3.export to PDF

Actual Results:
Resulted file, when opened in Firefox, give a warning about possibility of content being not displayed correctly.

Expected Results:
PDF file with typed text


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Preinstalled version 6.4.2.2 from Lubuntu 20.04
Build ID: 1:6.4.2-0ubuntu3
CPU threads: 2; OS: Linux 5.4; UI render: default; VCL: qt5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 max 2020-05-01 07:06:08 UTC
Created attachment 160172 [details]
exported PDF
Comment 2 Bart 2020-05-01 09:46:48 UTC
Max, if you upload the document with Latin and Cyrillic symbols, I can try to reproduce your problem.

Also, if you choose
   File -> Print -> Print Preview
then does the preview look right?

When you export to PDF, do you choose
   File -> Print -> Print to File ...
or do you choose
   File -> Export As -> Export As PDF ...

PS: I'm not a developer. I submitted a few bugs/reports myself and I'm trying to confirm the bugs that other people reported here.
Comment 3 max 2020-05-01 09:58:28 UTC
Created attachment 160176 [details]
text file
Comment 4 max 2020-05-01 09:58:57 UTC
File -> Print -> Print Preview --- looks alright
'File -> Print -> Print to File' and  'File -> Export As -> Export As PDF' give the same result
Comment 5 Bart 2020-05-01 16:23:00 UTC
I'm really sorry, but I can't reproduce this bug. 

I'm running Linux/Debian10 and I tried it with LibreOffice 6.1 , 6.3 , 6.4 and 7.0.

All the PDF's that I created looked correct. As an example I added attachment "testLO64fe.pdf". This PDF also looks correct when I open it in Firefox and Konqueror. To show what it looks like in these browsers, I added 
   "FirefoxTestLO64fe.png"
and
   "KonquerorTestLO64fe.png"

   Here's what I did:

I already had installed versions 6.1 , 6.3 and 7.0. Max, because you are using version 6.4.2.2, I also installed version 6.4.3.2.

Not every font supports every available character set. That's why I copied and pasted the line 
   "Test тест" 
and I changed the font of the second line to Cantarell.

In all cases I created the PDF's via
   File -> Print -> Print to File ...
and via
   File -> Export As -> Export As PDF ...

Max, 
- I made screen copy "FileExportAsPDF.png". Please check if you are using the same settings.
- Can you only view PDF's with Firefox, or can you also open them with programs like "Document Viewer" , "Atril Document Viewer" , another PDF utility or another browser?

					~~~

   Here are the versions that I used:

Firefox 68.7 esr (64 bit)

LibreOffice versions:

Version: 6.1.5.2
Build ID: 1:6.1.5-3+deb10u5
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group threaded

Version: 6.3.4.1
Build ID: a21169d87339dfa44546f33d6d159e89881e9d92
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.4.3.2
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Version: 7.0.0.0.alpha0+
Build ID: 4d03bd252274308f64332e7c0523068c38ac684a
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-04-26_05:59:56
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 Bart 2020-05-01 16:24:08 UTC
Created attachment 160186 [details]
testLO64fe.pdf
Comment 7 Bart 2020-05-01 16:25:11 UTC
Created attachment 160187 [details]
FirefoxTestLO64fe.png
Comment 8 Bart 2020-05-01 16:25:44 UTC
Created attachment 160188 [details]
KonquerorTestLO64fe.png
Comment 9 Bart 2020-05-01 16:26:37 UTC
Created attachment 160189 [details]
FileExportAsPDF.png
Comment 10 Timur 2020-05-02 17:10:31 UTC
This is not usually reproducible, so Lubuntu or qt5 or reporter's machine.
Comment 11 max 2020-05-02 18:19:35 UTC
(In reply to Timur from comment #10)
> This is not usually reproducible, so Lubuntu or qt5 or reporter's machine.

Alas, fresh install of lubuntu 20.04 with preinstalled libre. Previously lubuntu 18.04 with libre 6.3 work just fine. I'll wait. Maybe 20.04.1 will fix it
Comment 12 Bart 2020-05-02 21:38:24 UTC
Max, I just remembered that the document looks alright on your screen via:
   File -> Print -> Print Preview
and that could give you an alternative solution.

If you print to a piece of paper, and if that looks alright too, you could try to install an extra "Print to PDF" driver. There's a small chance that that solves your problem.
Comment 13 max 2020-05-02 21:57:33 UTC
(In reply to bart-dn from comment #12)
> Max, I just remembered that the document looks alright on your screen via:
>    File -> Print -> Print Preview
> and that could give you an alternative solution.
> 
> If you print to a piece of paper, and if that looks alright too, you could
> try to install an extra "Print to PDF" driver. There's a small chance that
> that solves your problem.

HI!
It's a great hint!
Although I've installed cups-pdf and exported doc with it .. and opened PDF without any warnings.. still no avail: it's empty.
However, preview works fine. Physical printer spits out empty page.

I'll dig into cups settings later.
Comment 14 max 2020-05-04 07:45:59 UTC
cups is alright, pdf's generated elsewhere prints ok. Thus is a problem of libre installation. Alas, I have to migrate to OnlyOffice, at least for now.
Comment 15 Timur 2020-05-04 14:54:39 UTC
max, you can try to find yourself what happens with other LO versions.
Simplest is to use AppImage runtime from https://libreoffice.soluzioniopen.com (from Old up to Daily 7.0+ master although it's old)

Also you may try to use other desktop env.  from commandline with: 'SAL_USE_VCLPLUGIN=gen soffice'
or
'SAL_USE_VCLPLUGIN=gtk3 soffice' ?
Comment 16 max 2020-05-04 20:02:23 UTC
(In reply to Timur from comment #15)
> max, you can try to find yourself what happens with other LO versions.
> Simplest is to use AppImage runtime from
> https://libreoffice.soluzioniopen.com (from Old up to Daily 7.0+ master
> although it's old)
> 
> Also you may try to use other desktop env.  from commandline with:
> 'SAL_USE_VCLPLUGIN=gen soffice'
> or
> 'SAL_USE_VCLPLUGIN=gtk3 soffice' ?

Different versions from soluzioniopen.com didn't work.
But changing desktop environment did! Both of them, though 'gen' one produced very outdated interface for my liking.

my VCL is QT5: echo $SAL_USE_VCLPLUGIN => qt5

In /usr/bin/startlxqt I have:
if [ -z "$SAL_USE_VCLPLUGIN" ]; then
    export SAL_USE_VCLPLUGIN=kde4
fi

Since my VCL var is not empty, I just added:
SAL_USE_VCLPLUGIN=gtk3 -- it didn't work.


So for now I edited desktop shortcut for writer in /usr/share/applications/libreoffice-writer.desktop:

libreoffice --writer ==> SAL_USE_VCLPLUGIN=gtk3; libreoffice --writer

and now it works fine.


Any suggestions for more elegant solution?
Comment 17 Timur 2020-05-04 20:33:29 UTC
looks like a duplicate.

*** This bug has been marked as a duplicate of bug 125234 ***