Bug 132589 - Caption frame doesn't shrink 'in ratio' (empty space at the bottom)
Summary: Caption frame doesn't shrink 'in ratio' (empty space at the bottom)
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
: 140644 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-05-01 15:03 UTC by Telesto
Modified: 2022-03-01 09:10 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (13.19 KB, application/vnd.oasis.opendocument.text)
2020-06-17 19:44 UTC, Telesto
Details
Screencast (531.56 KB, video/mp4)
2020-07-16 14:01 UTC, Telesto
Details
Screencast of alternative (1.69 MB, video/mp4)
2022-02-17 14:27 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-01 15:03:47 UTC
Description:
Caption frame doesn't shrink 'in ratio' (empty space at the bottom)

Steps to Reproduce:
1. Open the attached file
2. Click the right corner of the image frame and drag it outwards -> Frame & content expands proportionally 
3. No reduce the size by dragging 'inwards'
4. Caption frame doesn't resize properly

Actual Results:
Caption frame doesn't resize properly. Room at the bottom

Expected Results:
Should be resizing the same way as expanding


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: f845f74afaf087a46c82ee4209e29caca0980b71
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Bart 2020-05-03 03:50:32 UTC
(Pssst, there's no attached file. ;-) )
Comment 2 Xisco Faulí 2020-06-17 15:37:55 UTC
(In reply to Bart from comment #1)
> (Pssst, there's no attached file. ;-) )

Setting to NEEDINFO
Comment 3 Telesto 2020-06-17 19:44:49 UTC
Created attachment 162126 [details]
Example file
Comment 4 Leandro de Oliveira 2020-07-15 04:01:31 UTC
I have the same problem writer 6.4.4.2
Comment 5 Xisco Faulí 2020-07-16 10:32:10 UTC
Hi Telesto,
Could you please attach a screencast to make it clearer ?
Comment 6 Telesto 2020-07-16 14:01:45 UTC
Created attachment 163119 [details]
Screencast

Empty space below the caption
Comment 7 Buovjaga 2020-11-25 18:21:21 UTC
The behaviour is seen already in 3.3.0. It only happens, when you do not resize it uniformly, but shrink more in the x-axis. I'm not sure if this is a bug. Or should the initial behaviour of adding empty space to the bottom of the frame be considered a bug?
Comment 8 Heiko Tietze 2021-04-12 11:57:02 UTC
*** Bug 140644 has been marked as a duplicate of this bug. ***
Comment 9 Dieter 2022-02-17 13:20:02 UTC
Telesto, could you please retest with actual version of LO?
=> NEEDINFO
Comment 10 Telesto 2022-02-17 14:14:57 UTC
(In reply to Buovjaga from comment #7)
> The behaviour is seen already in 3.3.0. It only happens, when you do not
> resize it uniformly, but shrink more in the x-axis. 

True, I was pretty sure I did proportionally, but well apparently not

>I'm not sure if this is a bug. Or should the initial behaviour of adding empty >space to the bottom of the frame be considered a bug?

Well I kind of expect the corners shrinking the image proportionally by default


---
Still repro
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 2bb10a827ac13d0caf009e8526ccd9f17dc71653
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL Jumbo
Comment 11 Telesto 2022-02-17 14:27:22 UTC
Created attachment 178353 [details]
Screencast of alternative
Comment 12 Telesto 2022-02-17 14:42:21 UTC Comment hidden (obsolete)
Comment 13 Heiko Tietze 2022-02-18 09:26:36 UTC
First of all, it depends on whether you change the frame around objects or the object itself.

This ticket talks about the caption frame- and it is possible to keep the ratio by pressing shift while sizing. Works also for the object itself. Draw does the opposite and keeps the ratio by default while switching to the free mode per shift. This was decided a couple of years ago with the idea that scenarios differ and the implementation fits best the most relevant.

The white space results of course from the fact of a smaller content, eg. after you resized the frame from landscape to portrait. Admittedly, the procedure takes only the width into account when resizing the content, not the height. Putting all together the issue is NAB (with some aspects that might be discussed).

My take NAB. Agreed, Telesto?

By the way: https://help.libreoffice.org/latest/hr/text/swriter/01/04130100.html
Comment 14 Heiko Tietze 2022-03-01 09:10:55 UTC
(In reply to Heiko Tietze from comment #13)
> My take NAB.