Bug 132641 - Copy paste multiline (multiple paragraphs with list/numbering) creates a phantom duplicated line
Summary: Copy paste multiline (multiple paragraphs with list/numbering) creates a phan...
Status: RESOLVED DUPLICATE of bug 132187
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.4.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 132674 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-05-03 13:33 UTC by Marco Menardi
Modified: 2020-05-06 04:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screencast of the bug (178.96 KB, video/webm)
2020-05-03 13:35 UTC, Marco Menardi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Menardi 2020-05-03 13:33:35 UTC
Description:
Copy and paste of multiple lines creates a duplication of last line pasted that is a sort of "phantom" line (like in Emacs multiple cursor editor), what you write appears also in that, unreacheable, line below.

Steps to Reproduce:
1. open a new document, write 6 lines (put "1", "2"... on each line but the last)
2. go up, shift select line 2-4 (cursor reaches line 5)
3. copy (^c), move to line 6 then back to 5 and paste (^V)


Actual Results:
Now you have 5 times line 5! Cursor can't go down anymore (i.e. to this second 5th line, or to reach the 6st line), and what you write on line 5 is "duplicated" in it's "shadow" phantom line
(see brief video attached)

Expected Results:
You don't have a second 5 line, copy paste should work as usual


Reproducible: Always


User Profile Reset: No



Additional Info:
VERSION IS 6.4.4~rc1-1 (is not available under the Version list!), GNU/Linux Debian Sid, KDE
Comment 1 Marco Menardi 2020-05-03 13:35:54 UTC
Created attachment 160278 [details]
Screencast of the bug

Brief screencast of the bug
Comment 2 Bart 2020-05-03 16:12:30 UTC
Thank you for reporting this. I remember that I had something similar on my screen in the past. Back then I didn't keep the details, so I was happy with your bug report. 

I tried this with Linux/Debian10 and LibreOffice 6.1.5.2 , 6.3.4.1 , 6.4.3.2 and 7.0.0.0.alpha0+.

I can reproduce this with 7.0 , but not with the other ones. This makes me think that this first happened in 6.4.4. LibreOffice 7.0 shows me exactly what you have.

I set the status to "new".

PS: I'm not a developer. I'm a user myself and I submitted a few bug reports. I'm trying to confirm the bugs that other people report here.

					~~~

   Here are the versions that I used:

Version: 6.1.5.2
Build ID: 1:6.1.5-3+deb10u5
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group threaded

Version: 6.3.4.1
Build ID: a21169d87339dfa44546f33d6d159e89881e9d92
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.4.3.2
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Version: 7.0.0.0.alpha0+
Build ID: 4d03bd252274308f64332e7c0523068c38ac684a
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-04-26_05:59:56
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Marco Menardi 2020-05-04 20:38:35 UTC
$ git bisect good
6a226c611e759b48cdc0f1b60578836ecd7aaa44 is the first bad commit
commit 6a226c611e759b48cdc0f1b60578836ecd7aaa44
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Fri Apr 3 18:48:53 2020 +0200

    source sha:166b5010b402a41b192b1659093a25acf9065fd9
    
    source sha:166b5010b402a41b192b1659093a25acf9065fd9

:040000 040000 ff5232ec7bcaa9d94f0a99be5255b8dad9340dd0 6b318f05018572b44327569d928e39247a7aad7c M      instdir


$ git bisect log
# bad: [3228da8d278071bb62ee997c2c9dced4efc7ef58] source sha:4ba1909f12b49f020195b5e767045340717ce6df
# good: [d67926cda658cfe40d35f9f0f203c3407f3700c9] source sha:9bc848cf0d301aa57eabcffa101a1cf87bad6470
git bisect start 'origin/master' 'd67926cda658cfe40d35f9f0f203c3407f3700c9'
# good: [00b4dd1a0989cc91836bb6c3a7e739cdf0a1903b] source sha:c81d766dd4ff7d8b580b7fdc79db6e68c5f14204
git bisect good 00b4dd1a0989cc91836bb6c3a7e739cdf0a1903b
# good: [48a7ec8abb5a879245221497788a9d7dd2902291] source sha:3e7afb028ae10b02561f3f0e32cafadc18ec6bf3
git bisect good 48a7ec8abb5a879245221497788a9d7dd2902291
# bad: [b138869cc67dc25c001aa342e678439f3ec84a62] source sha:c40d3d741be4cdfe7263c8a9ec052f5f80869247
git bisect bad b138869cc67dc25c001aa342e678439f3ec84a62
# good: [6d71b9e74c4d1be17d4ed4df2ddf094161ba5efd] source sha:217625058109b39752710d70fb0ab0dd1bac7435
git bisect good 6d71b9e74c4d1be17d4ed4df2ddf094161ba5efd
# good: [bf49eef8cc9972db06e19e5fdf6d4f941774ac3e] source sha:14a0727889699128f02ac0a79bdce0103c89bc01
git bisect good bf49eef8cc9972db06e19e5fdf6d4f941774ac3e
# good: [9d58860ac2bff2c4d825c39e77ca2851eb9bdcdb] source sha:dff729704687889f960562f0ac6fa62b47897cf9
git bisect good 9d58860ac2bff2c4d825c39e77ca2851eb9bdcdb
# good: [bc1cac3484acd486b7ec57af849449f2a83f8e3e] source sha:af95bda66d4f114c5935a8ff4ca7ac0e6faec86a
git bisect good bc1cac3484acd486b7ec57af849449f2a83f8e3e
# bad: [e6b4525aed9299160284d8d4b2c094fc80d49f53] source sha:870314d155d37d6ad110aaaeb8ba2efa41446d5b
git bisect bad e6b4525aed9299160284d8d4b2c094fc80d49f53
# good: [db90627e1a667f6c0f42ac55eab4939fe92f4460] source sha:d7c9bb6b51f44b01b23134fb22c0902d85f31329
git bisect good db90627e1a667f6c0f42ac55eab4939fe92f4460
# bad: [98fea1befef7cc4fdf92842845f9777a39bd78f4] source sha:ab5ef15366b473db1068cc5a9e402c4f4f2e6fcd
git bisect bad 98fea1befef7cc4fdf92842845f9777a39bd78f4
# bad: [578cad60a1d1f185fb9d0e649b10a33fcf6ee428] source sha:520b0e1679d7a97aa3d91cfc95ca647339da7e84
git bisect bad 578cad60a1d1f185fb9d0e649b10a33fcf6ee428
# bad: [6a226c611e759b48cdc0f1b60578836ecd7aaa44] source sha:166b5010b402a41b192b1659093a25acf9065fd9
git bisect bad 6a226c611e759b48cdc0f1b60578836ecd7aaa44
# good: [075424ba508e056bc45c6cb900951b32bb4dd47b] source sha:27aa4b16bf704d0246595750daf57b57ff2577b3
git bisect good 075424ba508e056bc45c6cb900951b32bb4dd47b
# first bad commit: [6a226c611e759b48cdc0f1b60578836ecd7aaa44] source sha:166b5010b402a41b192b1659093a25acf9065fd9
Comment 4 Ming Hua 2020-05-04 22:24:13 UTC
*** Bug 132674 has been marked as a duplicate of this bug. ***
Comment 5 Cor Nouws 2020-05-05 07:17:00 UTC
@michael.stahl
 166b5010b402a41b192b1659093a25acf9065fd9 is yours.
(I didn't check if the fix for bug 132187 fixes this one too)


@mmenaz@mail.com : thanks for the report and bibisecting.
Possibly - I'm not sure how things work exactly nowadays - you need to ping someone too if bibisecting has been done, so that it is further handled.
Comment 6 Michael Stahl (CIB) 2020-05-05 08:55:54 UTC
yes its a duplicate, fixed on master

*** This bug has been marked as a duplicate of bug 132187 ***