Download it now!
Bug 132651 - UI: Changing the resolution by typing doesn't update width/height field
Summary: UI: Changing the resolution by typing doesn't update width/height field
Status: RESOLVED DUPLICATE of bug 122833
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-05-03 18:52 UTC by Telesto
Modified: 2020-06-07 18:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-03 18:52:05 UTC
Description:
Changing the resolution by typing doesn't update width/height

Steps to Reproduce:
1. Open Writer
2. File -> Export -> PNG
3. Press Save
4. Type a resolution into Resolution box (nothing happens)
5. Click the CM drop down -> Update

Actual Results:
No update after typing a resolution

Expected Results:
Should update as before in 4.4.7.2


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: b8fb7ecd9cdbe1898c41eaecd9894df8e8f01e25
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc:
Comment 1 Aron Budea 2020-06-07 04:14:43 UTC
To be clear, in step 4 Telesto's expectation is that width/height should be updated right when the resolution is typed in, while now it's only updated if you click away, or if you incremend/decrement the value using the spinners.

I'm not sure what the common behavior is, and whether it can reasonably be implemented, or it's a limitation of the spinbox. When the controls were text boxes, this worked as expected.

In LO 4.4 the dialog was much more simplistic, which changed a few versions later (in both cases these controls were text boxes). At that point changing the value directly triggers recalculation, but in 6.2 the value entry fields became spinboxes, and there's no immediate recalculation. Bibisected the latter change to the following commit with repo bibisect-linux-64-6.2. Adding CC: to Caolán McNamara.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c98578f9b8da2c9ff9525c13697ff33c4f00731d
author		Caolán McNamara <caolanm@redhat.com>	2018-10-05 11:26:09 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2018-10-05 17:12:11 +0200

weld ExportDialog
Comment 2 Caolán McNamara 2020-06-07 18:48:29 UTC
same as bug 122833, I thought I had a comment on that one, or one similar to that, that its deliberate to wait until focus moves out of the spinbutton to fire a value-changed signal vs sending one when the contents change, there are pro and cons on either approach but its certainly easier on the not-while-typing approach.

*** This bug has been marked as a duplicate of bug 122833 ***