Bug 132695 - Explanation of "Character Background" in "Tools - Options - Load/Save - Microsoft Office" is not too clear
Summary: Explanation of "Character Background" in "Tools - Options - Load/Save - Micro...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: sdc.blanco
URL:
Whiteboard: target:7.2.0
Keywords: difficultyBeginner, easyHack, skillDocumentation, topicDoc
Depends on:
Blocks: Options-Dialog-Load-Save Help-Changes-Features
  Show dependency treegraph
 
Reported: 2020-05-04 22:00 UTC by Gerald Pfeifer
Modified: 2021-02-10 08:19 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2020-05-04 22:00:46 UTC
In the context of the lengthy discussions in
  https://bugs.documentfoundation.org/show_bug.cgi?id=125268
I went to the documentation at
  https://help.libreoffice.org/7.0/en-US/text/shared/optionen/01130200.html
and found that a little, um, dense:

     "Microsoft Office has two character attributes similar to
     LibreOfficeDev character background. Select the appropriate 
     attribute (highlighting or shading) which you would like to 
     use during export to Microsoft Office file formats."

It would be great to enhance this and guide which choice to make in what case.

I am not an expert, but definitely volunteer to help assess any changes on
whether they would have helped clarify the situation for me as a user.

Perhaps the following suggested addition can be a start? 

     "Shading tries to maintain color fidelity between LibreOffice and
     Microsoft Office to the extent possible. Choose this if interoperability
     is your primary concern.  Highlighting uses a brighter color palette when
     exporting to Microsoft Office formats, which makes text stand out more
     strongly while creating more of a visual difference. Choose this if your
     priority is the highlighting effect over visual fidelity."
Comment 2 Justin L 2020-11-21 18:52:14 UTC
"Highlighting only supports a limited number of colours, but it matches the normal tool that Word uses to add or remove character backgrounds, so in most cases this is the better, interoperable choice."

"Shading maintains colour fidelity at all costs. Only use shading if MS Word users will not be editing the document."
Comment 3 sdc.blanco 2021-01-19 16:08:21 UTC
@Gerald -- good suggestion -- and thanks for proposing some text...which seems to contradict what Justin has written.

(In reply to Justin L from comment #2)
Thanks for suggestions.  A few questions of clarification...

> "Highlighting ... matches the normal tool that Word uses to add or remove
> character backgrounds, 
This means that Word users can edit character highlighting (made with LO "Highight Color") with no surprises?

> Only use shading if MS Word users will not be editing the document."
Should this be interpreted to mean "not editing at all"  or "not editing the places where character highlighting was applied"?
Comment 4 sdc.blanco 2021-01-19 16:22:41 UTC
According to   https://help.libreoffice.org/7.2/en-US/text/shared/optionen/01130200.html

"Microsoft Office has two character attributes similar to LibreOffice character background."

@Mike -- is this accurate?  Shouldn't it be "LibreOffice character highlighting"?
or maybe "paragraph background"?
Comment 5 Justin L 2021-01-19 17:54:23 UTC
(In reply to sdc.blanco from comment #4)
> "Microsoft Office has two character attributes similar to LibreOffice
> character background."
> 
> Is this accurate? Shouldn't it be "LibreOffice character highlighting"?
> or maybe "paragraph background"?
Don't mix "paragraph" into this. Paragraph highlighting is a completely different setting in both Word and LibreOffice. (It is the "area" tab in the paragraph style. The highlighting tab in the paragraph style is the character property that we are discussing here.)

So yes, character highlighting is the better term to use since it matches the tab and toolbar names.
Comment 6 Mike Kaganski 2021-01-20 06:16:59 UTC
Two user-visible issues here:

1. Word's two attributes that define character background have different color repertoire. Shading can represent any RGB color, while highlighting only allows using 16 colors. The issue here is the fidelity of the color; user needs to consider if keeping applied color unchanged is more important (one aspect of interoperability, mentioned by comment 0: is the document interoperable in the sense that its character background looks identically in both suites, with shading being more "interoperable" in this aspect).

2. Word's two attributes have different usability, making highlighting very prominent, while keeping shading well-hidden. This makes a Word user confused when shading is present in the document, and user tries to use the familiar highlighting tool to remove the color without success, without realizing that their tool (Word) has more controls (another aspect of interoperability, mentioned in comment 2: can the users of the other suite *easily handle* this visual effect, with highlighting being more "interoperable" in this aspect).

These two aspects do not "contradict" with each other, they complement each other to create a whole picture to consider.
Comment 7 sdc.blanco 2021-01-20 07:31:29 UTC
Proposed text

---------------------

Character Highlighting

Microsoft Office has two character attributes similar to LibreOffice character highlighting. Use this control to select the attribute, highlighting or shading, that LibreOffice should use when exporting LibreOffice character highlighting to Microsoft Office file formats.

Highlighting exports only 15 colors, using the Office character attribute that makes it easy for Office users to edit with the highlighting tool in Office applications. This is the default setting in LibreOffice 5.0 to 6.4.

Shading exports all RGB colors to the other Office character attribute. This preserves color fidelity between LibreOffice and Microsoft Office documents, but Office users must edit this character attribute with a tool that is not commonly used or easy to find in Office applications. This is the default setting since LibreOffice 7.0.

------------

Comments:  As implied from comment 6, what is "best" or "preferred" depends on what you are trying to do. Therefore, rather than trying to tell LO users what to use, it seems better to simply provide sufficient relevant information for LO users to make an informed choice, according to their situation.  

@Gerald, and others -- what do you think?
Comment 8 Mike Kaganski 2021-01-20 08:02:26 UTC
(In reply to sdc.blanco from comment #7)
> Highlighting exports only 15 colors

A nitpick: there are 16 possible values mandated by MS documentation, plus "none":

black
blue
cyan
green
magenta
red
yellow
white
darkBlue
darkCyan
darkGreen
darkMagenta
darkRed
darkYellow
darkGray
lightGray
none

So 16, not 15.
Comment 9 Mike Kaganski 2021-01-20 08:07:24 UTC
(In reply to sdc.blanco from comment #7)
> Highlighting exports only 15 colors, using the Office character attribute
> that makes it easy for Office users to edit with the highlighting tool in
> Office applications. This is the default setting in LibreOffice 5.0 to 6.4.

We need to add here that when this option is selected, actual color used in LO will be changed into the closest match from the available highlighting colors.
Comment 10 Justin L 2021-01-20 09:04:54 UTC
(In reply to Mike Kaganski from comment #8)
> So 16, not 15.
Right you are. I always just trusted Tamás Zolnai when he corrected himself and say "15 colours actually) in bug 125268 comment 10.

So actually his MS compatible palette in LO should add white as a colour too.
Comment 11 Mike Kaganski 2021-01-20 09:09:10 UTC
(In reply to Justin L from comment #10)
> I always just trusted Tamás Zolnai when he corrected himself
> and say "15 colours actually) in bug 125268 comment 10.
> 
> So actually his MS compatible palette in LO should add white as a colour too.

There might be opinions; white is not offered by MS Word's Highlight control palette, so in a sense, Word actually only offers 15 colors (in GUI) ... no idea how to handle this additional Word quirk, maybe sticking to what its GUI has is OK.
Comment 12 sdc.blanco 2021-01-20 09:50:11 UTC
Revised "highlighting" paragraph proposal (and thanks for confirming my speculation about how conversion was working.)

------

Highlighting exports the closest match between a LibreOffice highlighting color and one of the 16 Microsoft highlighting colors, using the Office character attribute that makes it easy for Office users to edit with the highlighting tool in Office applications. This is the default setting in LibreOffice 5.0 to 6.4.

--------

Microsoft highlighting colors?
or
Office highlighting colors?
Comment 13 sdc.blanco 2021-01-20 09:50:44 UTC
Maybe a <tip> at the end?

The compatibility filter in the Character Highlighting Color dialog provides the Microsoft Office highlighting colors.


Is that statement correct? (with correct terminology?)

Rationale: Assumes that the observant help reader will be able to figure out: "use the compatibility filter to get color fidelity and ease of MS editing"
Comment 14 Mike Kaganski 2021-01-20 09:55:06 UTC
(In reply to sdc.blanco from comment #13)
> Rationale: Assumes that...

Do not assume anything about audience. Just state directly: "... use it to get the same colors when editing in LO as will be exported into MS formats ...". A small sentence will not hurt. Even if you think something makes text too long, do not omit it, but just make it expandable.
Comment 15 sdc.blanco 2021-01-20 10:05:13 UTC
Revised tip proposal:

------------

The compatibility filter in the Character Highlighting Color dialog provides the Microsoft Office highlighting colors. Use those colors if you want both color fidelity and ease of editing for Office users.

---------------
Comment 16 sdc.blanco 2021-01-20 10:06:00 UTC
Meanwhile -- the compatibility filter does not include "white" as noted in comment 10 -- and the tooltip labels for the colors do not correspond fully to the list in comment 8. Is that because the labels are wrong? (and not the colors)?

I could not see any bug report filed about this.  Should there be?
Comment 17 sdc.blanco 2021-01-20 10:09:29 UTC
Sorry -- slightly more explicit, less ambiguous tip:

-----------------

The compatibility filter in the Character Highlighting Color dialog provides the Microsoft Office highlighting colors. Use those colors and choose "Export as Highlighting" if you want both color fidelity and ease of editing for Office users.
Comment 18 Justin L 2021-01-20 15:27:45 UTC
(In reply to Mike Kaganski from comment #11)
> Word actually only offers 15 colors (in GUI), maybe sticking to what its
> GUI has is OK.
Probably this is the best, especially since they have a different documented standard for DOC and DOCX - and use the wrong words to describe the RGB codes they use in some cases.

For documentation purposes, I'll post here that I started http://gerrit.libreoffice.org/c/core/+/109666 tdf#125268: Add white to compatibility palette
but I'm going to abandon it since it seems impossible to have a "right" answer.
Comment 19 Gerald Pfeifer 2021-01-20 17:50:54 UTC
(In reply to sdc.blanco from comment #7)
> @Gerald, and others -- what do you think?

This (= the original text with updates in later comments) really makes
a difference and nicely explains the situation. It would have helped me
quite a bit back then and hopefully will help new users in the future.

Thank you!
Comment 20 Commit Notification 2021-01-20 23:08:03 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/e9b5c5c090e4874daf878dd555329bfed6c07229

tdf#132695 export of character highlighting to MS Word - improve help
Comment 21 sdc.blanco 2021-01-20 23:12:14 UTC
(In reply to Gerald Pfeifer from comment #19)
Thanks very much for the feedback Gerald, and thanks to Justin and Mike for help with safe navigation through this colourful minefield.