Bug 132745 - Address Book Assignment crashes on Mac Os X address book
Summary: Address Book Assignment crashes on Mac Os X address book
Status: RESOLVED DUPLICATE of bug 126961
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-05 21:13 UTC by andrew@aehrlich.com
Modified: 2020-05-07 08:15 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andrew@aehrlich.com 2020-05-05 21:13:53 UTC
Description:
Unable to add Mac Os X system address book as a data source.

Steps to Reproduce:
Tools -> Address Book Source
Assign
Mac Os X Address book.

Actual Results:
Libreoffice crashes. 

Expected Results:
To be able to load the new data source.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Mac OS 10.14.4

I have never tried this feature before, so I don't know whether it ever worked.
Comment 1 Alex Thurgood 2020-05-07 08:11:15 UTC
@andrew : it did work before, albeit with intermittent problems such as the one you are reporting.

Unfortunately, I can not reproduce this 

Version : 6.4.3.2
Build ID : 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
Threads CPU : 8; OS : Mac OS X 10.15.4; UI Render : par défaut; VCL: osx; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded


The first time you try this, you should get a message from the OS asking you to authorize access by LO to the Mac Address book. Did you see such a message ? Often it can be hidden behind the main LO screen, and is not always displayed on top. Additionally, it can sometimes take a very long time to display that message.


As I don't have a 10.14 version to test against any more, I can't say whether Apple has introduced stricter security measures (which may require you to grant wider access to system resources like the address book), or whether something has changed in the current release of LO that is causing the issue.
Comment 2 Alex Thurgood 2020-05-07 08:15:43 UTC

*** This bug has been marked as a duplicate of bug 126961 ***