Bug 132796 - A specific XLS (BIFF5) file opens with Cyrillic characters garbled
Summary: A specific XLS (BIFF5) file opens with Cyrillic characters garbled
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.3.2 release
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:7.0.0
Keywords:
: 35208 90210 94382 96330 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-05-07 07:08 UTC by Mike Kaganski
Modified: 2021-09-03 07:40 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
An XLS (BIFF5) without proper codepage specified in the file, assumed Win-1251 (634.00 KB, application/vnd.ms-excel)
2020-05-07 07:08 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2020-05-07 07:08:09 UTC
Created attachment 160477 [details]
An XLS (BIFF5) without proper codepage specified in the file, assumed Win-1251

The attached file (presumably generated using some 3rd-party generator) lacks explicit codepage (assumed Win-1251). Opening it in Calc with Russian locale and Russian default document language, all Cyrillic characters get garbled (i.e., Win-1252 is used instead of Win-1251).

Excel 2016 on Russian Windows OS opens this file correctly. On English OS, Excel emits "File error. Some number formats may have been lost.", and opens with garbled Cyrillic characters, as in Calc.

Tested with Version: 6.4.3.2 (x64)
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 2 Commit Notification 2020-05-07 10:24:28 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ac0112ecefd64094b150390fc36f9f56d19a4d87

tdf#132796: use LO language settings to set default XLS language

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Kevin Suo 2020-12-30 03:38:20 UTC
*** Bug 35208 has been marked as a duplicate of this bug. ***
Comment 4 Kevin Suo 2020-12-30 03:39:48 UTC
*** Bug 94382 has been marked as a duplicate of this bug. ***
Comment 5 Kevin Suo 2020-12-30 03:40:42 UTC
*** Bug 96330 has been marked as a duplicate of this bug. ***
Comment 6 Mike Kaganski 2021-09-03 07:27:33 UTC
*** Bug 90210 has been marked as a duplicate of this bug. ***