Bug 132936 - Incorrect origin creating new selection after copy/paste
Summary: Incorrect origin creating new selection after copy/paste
Status: RESOLVED DUPLICATE of bug 42535
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-10 23:27 UTC by strata_ranger
Modified: 2020-05-11 08:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description strata_ranger 2020-05-10 23:27:32 UTC
Description:
In Calc, if you use Shift+arrow keys to make a contiguous rectangular selection *immediately* after a paste operation, LO the new selection's opposite corner is initialized at A1 instead of the current cell.

Steps to Reproduce:
1- In Calc, select any range of cells using the keyboard only (Shift+arrows); the actual size of selection does not matter (even a single cell will do).
2- Copy the selection, then paste it any convenient distance from the origin (e.g. G10).
2- Immediately start making a new selection via keyboard only (Shift+arrows).

Actual Results:
The second selection originates at the pasted location but its other corner is assumed to be A1 (plus whatever arrow key was used).

Expected Results:
There should be no difference between step 1 and step 3 above.


Reproducible: Always


User Profile Reset: No



Additional Info:
Tested and present against both of the following installs:

Version: 6.3.6.2 (x64)
Build ID: 2196df99b074d8a661f4036fca8fa0cbfa33a497
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

Version: 6.0.6.2 (x64)
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: en-US (en_US); Calc: group
Comment 1 m.a.riosv 2020-05-11 08:09:20 UTC
This is an old bug.

*** This bug has been marked as a duplicate of bug 42535 ***