Download it now!
Bug 132966 - Area Bitmap Scrollbar doesn't include newly added items (unreachable) after insertion (only with arrows; or after change to different tab)
Summary: Area Bitmap Scrollbar doesn't include newly added items (unreachable) after i...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.0.1
Keywords: bibisected, bisected, regression
: 134258 (view as bug list)
Depends on:
Blocks: Area-Fill-Tab-Bitmap
  Show dependency treegraph
 
Reported: 2020-05-11 20:07 UTC by Telesto
Modified: 2020-07-01 06:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-11 20:07:48 UTC
Description:
Area Bitmap Scrollbar doesn't include newly added items (unreachable) after insertion (only with arrows; or after change to different tab first)

Steps to Reproduce:
1. Open Writer
2. page Style -> Area -> Bitmap -> Insert a bitmap
3. Scroll up
4. Scroll back again -> image out of reach.. Press arrow down.. fine

Actual Results:
Unreachable 

Expected Results:
Should be reachable


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha0+ (x64)
Build ID: 97a2c1fc5e376c0c00968f17a0392c6d3a5ed565
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: threaded
Comment 1 Telesto 2020-05-11 20:08:17 UTC
Fine in 6.0.0.6
Comment 2 Buovjaga 2020-06-14 15:14:38 UTC
Bibisected with Win 6.2 repo to https://git.libreoffice.org/core/+/79daf40ec696e0855d4a2894f048e44188cfbbb6%5E!/
weld SvxAreaTabPage

Adding Cc: to Caolán McNamara
Comment 3 Commit Notification 2020-06-14 19:56:26 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b31bcdd8322b57dc0cd5b093b8f3e8e59b32c37e

Resolves: tdf#132966 flag scrollbar to reformat when QueueReformat called

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2020-06-14 19:56:32 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5cce65171b12cd652d6a9857a9c0bad1c608a65c

Related: tdf#132966 scrollbar not tracking valueset cursor position

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2020-06-15 09:55:59 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/220761aefb5014109877c8baac226f8acb9d3bed

Resolves: tdf#132966 flag scrollbar to reformat when QueueReformat called

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2020-06-15 10:00:02 UTC
that seems to do the right thing
Comment 7 Commit Notification 2020-06-15 11:16:44 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/3a3ab9c95c37bdd84fdceac82349621368e1bee1

Related: tdf#132966 scrollbar not tracking valueset cursor position

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Buovjaga 2020-06-15 13:00:11 UTC
Verified, thanks!

Arch Linux 64-bit
Version: 7.1.0.0.alpha0+
Build ID: 43bdac0ebd65dfc32a0b8cf2c42fde88ad585e3f
CPU threads: 8; OS: Linux 5.7; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 15 June 2020
Comment 9 BogdanB 2020-06-23 21:01:31 UTC
*** Bug 134258 has been marked as a duplicate of this bug. ***