Bug 132985 - In German locale U+0027 (typewriter apostrophe) gets replaced with U+2018 (left single quotation mark) instead of U+2019 (apostrophe, right single quotation mark)
Summary: In German locale U+0027 (typewriter apostrophe) gets replaced with U+2018 (le...
Status: RESOLVED DUPLICATE of bug 128860
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-12 19:25 UTC by tobias
Modified: 2020-05-12 19:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tobias 2020-05-12 19:25:21 UTC
Description:
I want to write a sentence containing an apostrophe

Steps to Reproduce:
1. Write sentence containing apostrophe (input U+0027)
2. "Tobias' Fehlermeldung"


Actual Results:
U+0027 gets replaced with U+2018
"Tobias‘ Fehlermeldung"

Expected Results:
U+0027 should get replaced with U+2019
"Tobias’ Fehlermeldung"


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.4.2.2
Build-ID: 1:6.4.2-0ubuntu3
CPU-Threads: 8; BS: Linux 5.4; UI-Render: GL; VCL: kf5; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded

Setting: Extras/Autokorrektur/Autokorrektur-Optionen Tab: "Gebietsschemaabhängige Optionen" Setting "Einfache Anführungszeichen" "Ersetzen" activated. Turning this off gives me the expected apostrophe replacement. But then I don't get the single quotation marks anymore …
Comment 1 Ming Hua 2020-05-12 19:53:57 UTC
Hi Tobias,

Thanks for reporting.  This issue about autocorrect in German locale has already been reported as bug 128860, so I'm marking it as a DUPLICATE.

Please follow the discussion there.  Meanwhile if you disagree this is a duplicate feel free to state the reason in a comment and change it back.

*** This bug has been marked as a duplicate of bug 128860 ***