Bug 132996 - Positioning of measurement dropdown is wrong
Summary: Positioning of measurement dropdown is wrong
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.0.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-05-13 08:37 UTC by Heiko Tietze
Modified: 2020-06-01 14:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (75.88 KB, image/png)
2020-05-13 08:37 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2020-05-13 08:37:15 UTC
Created attachment 160744 [details]
Screenshot

Likely introduced with this patch https://gerrit.libreoffice.org/c/core/+/82534/ (no reference to BZ, no reviewer!), the dropdown is unnecessary large (could align with other inputs).

Version: 7.0.0.0.alpha1+
Build ID: 1ffe59ef31186e36ad0aa7bbcdd32e407ee8d26c
CPU threads: 8; OS: Linux 5.6; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Heiko Tietze 2020-05-13 08:42:48 UTC
The checkbox below the label looks not balanced since the reference changes from input controls (dropdowns, edit fields etc.) to indentation of frame and alignment to labels.
Comment 2 andreas_k 2020-05-13 09:16:47 UTC
there is no expand selected however I will update the ui file.
Comment 3 Xisco Faulí 2020-05-13 12:17:50 UTC
(In reply to Heiko Tietze from comment #0)
> Likely introduced with this patch
> https://gerrit.libreoffice.org/c/core/+/82534/ (no reference to BZ, no
> reviewer!), the dropdown is unnecessary large (could align with other
> inputs).


Wrong commit. Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c3a03f03187b697bce84a9efa2de9964eb5466a1

author	Caolán McNamara <caolanm@redhat.com>	2020-05-01 15:06:23 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2020-05-01 17:48:57 +0200
commit	c3a03f03187b697bce84a9efa2de9964eb5466a1 (patch)
tree	0e3b78fe9c6f11ee6ad18e09acc14988bec93035
parent	b540e8bc7111ba03ee675a507c098e140a5e81dc (diff)
transfer halign and valign also

Bisected with: bibisect-linux64-6.5

Adding Cc: to Caolán McNamara
Comment 4 andreas_k 2020-05-13 12:25:46 UTC
patch is already in gerrit.

https://gerrit.libreoffice.org/c/core/+/94109

Heiko will review and than the bug is closed.
Comment 5 Commit Notification 2020-05-19 10:22:23 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8fee3f553bf396fad0237f19873e10c08782660f

Resolves tdf#132996 - Wrong position/scaling of dropdown

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2020-06-01 14:19:36 UTC
Verified in

Version: 7.0.0.0.beta1+
Build ID: 2506d8221dd940dfd93d3d7c183430ba6ba3089d
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Heiko, thanks for fixing this issue!