Download it now!
Bug 133098 - Crash changing form properties (Text type from multi-line to single line or visa versa)
Summary: Crash changing form properties (Text type from multi-line to single line or v...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0
Keywords: bibisected, bisected, haveBacktrace, needUITest, regression
Depends on:
Blocks:
 
Reported: 2020-05-16 18:52 UTC by Telesto
Modified: 2020-05-19 12:05 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (125.26 KB, application/vnd.oasis.opendocument.text)
2020-05-16 18:52 UTC, Telesto
Details
Screencast (448.10 KB, video/mp4)
2020-05-16 19:00 UTC, Telesto
Details
bt with debug symbols (gen) (11.03 KB, text/plain)
2020-05-17 09:40 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-05-16 18:52:34 UTC
Description:
Crash changing form properties (Text type from multi-line to single line or visa versa)

Steps to Reproduce:
1. Open the attached file (based on bug 107092)
2. Go to design mode (from design toolbar)
3. Double click this one  
4. Scroll down for text type (nearly at the bottom)
5. Hoover of the box and scroll up down using the scroll wheel or select multiline single line etc.. -> Crash

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.0.0.alpha1+ (x64)
Build ID: f9790da286f2d2fa47f1748f8cfa6172c6622ca3
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: de-CH (nl_NL); UI: en-US
Calc: CL

but not in 
6.4.3
Comment 1 Telesto 2020-05-16 18:52:46 UTC
Created attachment 160909 [details]
Example file
Comment 2 Telesto 2020-05-16 18:58:05 UTC
vcl::Window::GetParentWithLOKNotifier+0x57:
Comment 3 Telesto 2020-05-16 19:00:03 UTC
Created attachment 160910 [details]
Screencast

Alternative route: switch focus between form & editor
Comment 4 Julien Nabet 2020-05-17 09:40:10 UTC
Created attachment 160926 [details]
bt with debug symbols (gen)

On pc Debian x86-64 with master sources updated today, I had a crash just when double click second box at top right.
Only with gen rendering, not gtk3.
Comment 5 Julien Nabet 2020-05-17 09:41:34 UTC
Oups, it's not gen only, I could reproduce this too with gtk3.
Comment 6 Julien Nabet 2020-05-17 10:10:09 UTC
(In reply to Julien Nabet from comment #5)
> Oups, it's not gen only, I could reproduce this too with gtk3.

I really should double check sometimes.

I can reproduce this with gen and kf5 rendering but NOT with gtk3.
Comment 7 Julien Nabet 2020-05-17 10:37:44 UTC
Caolán: thought you might be interested in this one. Indeed, in this one I can't reproduce crash with gtk3 but could do with gen and kf5 rendering. (see bt attached).
Quite weirdly, I put a break here:
#1  0x00007fff873b9a02 in pcr::OPropertyEditor::RemovePage(unsigned short) (this=0x8f70840, nID=2) at extensions/source/propctrlr/propertyeditor.cxx:155
and noticed that when using gtk3, we don't enter there.
Comment 8 Attila Baraksó (NISZ) 2020-05-17 11:22:40 UTC
Bibisected using bibisect-win64-6.5 to:
URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=1efeb17837c22499f00299c033ae59ba3910f7d7
author: Caolán McNamara <caolanm@redhat.com>
committer: Caolán McNamara <caolanm@redhat.com> 
summary: weld Property Browser
Comment 9 Caolán McNamara 2020-05-17 19:46:55 UTC
looks like trying to unparent a vcl::Control doesn't do what I wanted it to do
Comment 10 Commit Notification 2020-05-18 20:12:27 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f7ceb1f805b45cbd4b322da2ca4039d56dd430b3

tdf#133098 cannot truly unparent a vcl widget

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Caolán McNamara 2020-05-18 20:15:01 UTC
that seems to be the problem here
Comment 12 Xisco Faulí 2020-05-19 11:57:34 UTC
@Telesto, could you please confirm the issue is fixed ?
Comment 13 Xisco Faulí 2020-05-19 12:05:13 UTC
Nevermind. Can reproduce the original crash with gen and I do confirm is fixed in

Version: 7.0.0.0.alpha1+
Build ID: 8209c2569f5726f9ed29f75d30efdccb94f98fe5
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!