Download it now!
Bug 133132 - Split launcher shortcuts for macOS, like in Linux
Summary: Split launcher shortcuts for macOS, like in Linux
Status: RESOLVED DUPLICATE of bug 50278
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Mac OS X (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-05-17 19:52 UTC by jvisser
Modified: 2020-07-05 03:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
.app LibreOffice shims (2.81 MB, application/octet-stream)
2020-05-17 19:53 UTC, jvisser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jvisser 2020-05-17 19:52:14 UTC
Description:
I've made separate macOS standalone launcher .app shims that launch Writer, Impress, Draw, Math, etc., just like LibreOffice works in Linux.
They are nothing more than an Automator script that executes `/Applications/LibreOffice.app/Contents/MacOS/soffice --writer "$@" >/dev/null 2>&1 &`
Because it supports args you can even drag files onto whichever of these .app bundles you have on the dock, and it'll open the file in the relevant LibreOffice program.

As one of the most oft requested features for Mac is 'can I please have a way to separately install Writer or a way to launch the separate aspects of LibreOffice', this should do nicely.

If wanted, now the fat binary could even be 'hidden' somewhere in the Application Support folder, and just the shims could be placed in /Applications.

One thing: whilst the shims can be placed anywhere, LibreOffice has to be installed in its default location, since that is what the shell line inside the .app shim expects.

Cheers and I hope this will be useful :)

Steps to Reproduce:
-

Actual Results:
-

Expected Results:
-


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 jvisser 2020-05-17 19:53:47 UTC
Created attachment 160945 [details]
.app LibreOffice shims
Comment 2 Ahmad Haris 2020-07-04 03:55:01 UTC
I would love to have this separate launcher also in MacOS
Comment 3 Rizal Muttaqin 2020-07-04 04:01:31 UTC
Add UXEval to investigate

@Heiko, can this be done? I would like to see this one. May be we can go further providing macOS style specific icon app also?
Comment 4 Heiko Tietze 2020-07-04 20:34:33 UTC

*** This bug has been marked as a duplicate of bug 50278 ***