Download it now!
Bug 133258 - [FORMATTING] Text layout varies wildly across docs, styles the same
Summary: [FORMATTING] Text layout varies wildly across docs, styles the same
Status: RESOLVED DUPLICATE of bug 38194
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-22 03:49 UTC by Luke Kendall
Modified: 2020-05-22 16:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Zip file of sample documents and screen shots (3.96 MB, application/zip)
2020-05-22 03:49 UTC, Luke Kendall
Details
Example file (25.52 KB, application/vnd.oasis.opendocument.text)
2020-05-22 10:11 UTC, Telesto
Details
Example file (16.00 KB, application/vnd.oasis.opendocument.text)
2020-05-22 10:16 UTC, Telesto
Details
Example file (15.76 KB, application/vnd.oasis.opendocument.text)
2020-05-22 13:47 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke Kendall 2020-05-22 03:49:48 UTC
Created attachment 161110 [details]
Zip file of sample documents and screen shots

I have two versions of my books that use the same basic layout. One is for a Kindle edition, one is for print.
I just noticed the text layout is wildly different on the first page.

Examples, from p1 (the Prologue):

line 7: "of warmth and hope back into the shocked faces around"
-> 
line 7: "of warmth and hope back into the shocked faces"

Following lines like:
"There would be no way to make this right, he knew."

and many others.

The page sizes are exactly the same: I have checked every property visible via the style inspector for the style (Body_N_HdrFtr).
The paragraph styles are exactly the same: I have checked every property visible via the style inspector for the style (Text Body).

The text layout differs wildly.

Please see attached screen shots and sample documents.
Comment 1 Telesto 2020-05-22 08:50:42 UTC
Thanks for reporting..

We have the state before, and the state after.. Any knowledge about what you did change?
Comment 2 Luke Kendall 2020-05-22 09:04:41 UTC
I'm sorry, I can't remember.

From the presence of many "ConvertN" styles though, and from my dim memory, there was a round trip from a .docx format for some reason.  It was years ago that I needed to do that, and I can't even remember why now, sorry.

Do you think it's also a concern that the layout can be so different (presumably due to some setting), that can't be discovered through the Writer UI?
Comment 3 Telesto 2020-05-22 10:11:40 UTC Comment hidden (obsolete)
Comment 4 Telesto 2020-05-22 10:16:12 UTC
Created attachment 161128 [details]
Example file

Better example file

1. Copy the text on page 2
2. Paste it on page 1
Comment 5 Telesto 2020-05-22 10:23:08 UTC
@Heiko
An clue what's causing this.. when following comment 4.. 
Why does "There would be no way to make this right, he knew." get a different layout.. 

It's already happening in 3.5.7.2
Comment 6 Heiko Tietze 2020-05-22 12:49:57 UTC
(In reply to Telesto from comment #5)
> An clue what's causing this.. when following comment 4.. 

Page layout > Mirrored > 2.3cm/1.5cm; probably also differences in PS/CS/DF

(In reply to Luke Kendall from comment #0)
> Created attachment 161110 [details]

WT-KDP 

Page style: 2.29/1.52/1.02/0.76

"PROLOGUE" - PS = "CSP - Chapter Title", CS = "Header Char", DF = font color, below paragraph 0.5cm
"Chief High Cloud" - PS = ChapterBdy1st (later it's Text Body), CS = Default, DF = seems to be none

WT-5x8-correct

Page style: 2.33/1.27/0.85/0.74
"PROLOGUE" - PS = "Chapter Title", CS = "Default", DF = spacing 5.29 before...
"Chief High Cloud" - PS = ChapterBdy1st, CS = Default, DF = seems to be none


This is not a bug. The underlying enhancement request is to clearly show what attributes are set at the cursor => DUP.
See also https://design.blog.documentfoundation.org/2019/11/05/proposal-to-conveniently-highlight-and-inspect-styles-in-libreoffice-writer/

@Luke: Be careful with the styles and don't use DF. I would ctrl+A + Remove Direct Formatting, set Default CS for all text, and also clear the PS. Then I'd start to format the outlines, later the chapters (don't see need for more than text body) and finally format citation with a dedicated CS. You may add special PS for the spacial first pages or just DF it.

*** This bug has been marked as a duplicate of bug 38194 ***
Comment 7 Telesto 2020-05-22 13:47:50 UTC
Created attachment 161146 [details]
Example file

OK, now I found the real issue :-)
Page 1: Has the default page style 
Page 2: Body_N_HdrFtr 

Settings are slightly different.. producing different results
Comment 8 Luke Kendall 2020-05-22 14:30:39 UTC
Ahh!

That explains why when I cleared direct formatting it made no difference.

Thank you, I agree this bug is resolved, and was not a bug.

And I couldn't find differences in style because I only looked at the page styles I thought were in use (and the paragraph styles).


"@Luke: Be careful with the styles and don't use DF. I would ctrl+A + Remove Direct Formatting, set Default CS for all text, and also clear the PS."

That's not really practical. In a 130,000 word book, working from a printed copy so as to re-apply all the italics alone (99.99% of changed character styles), that would require at minimum 3 mins work per page, so would work out to at minimum 23 hours of work. On top of that there would be a day or two of applying the 0.01% of other style information.

"Then I'd start to format the outlines, later the chapters (don't see need for more than text body) and finally format citation with a dedicated CS. You may add special PS for the spacial first pages or just DF it."

I would indeed need a small number of styles.  Most books are formatted consistently, not with complex sets of styles.  Apart from special paragraph styles across the front matter of the book (like the title and publication, dedication, Contents and so on), most books just need a zero-indent section-start paragraph style, a body text style, and a chapter heading style.

In principle it should be super simple, yes.

Thanks once again.  I'm terribly sorry I failed to notice that first page in the KDP version was Convert8.

I'm not sure I would have ever worked that out - I was blind to it.

Is there some way to generate a report of all styles (Pages, Sections, Paragraphs, Characters) actually used in a document?

If I had seen any page formats used other than the no-header-or-footer style, the main page style, and maybe an index style, I would probably have noticed and tracked down the error.
Comment 9 Heiko Tietze 2020-05-22 14:40:33 UTC
(In reply to Luke Kendall from comment #8)
> I'm terribly sorry I failed to notice that first page...

And I'm super happy to resolve issues quickly without making the OP angry ;-).

> Is there some way to generate a report of all styles (Pages, Sections,
> Paragraphs, Characters) actually used in a document?

Not inbuilt but we try to address this need for feedback with the implementation of the mentioned blog post idea. Not promising anything a positive outcome but the GSoC project has started.
Comment 10 Luke Kendall 2020-05-22 14:47:42 UTC
Thanks - good to know!

Come to think of it, there is no way to find a page style in a document, is there?  You can't search for it?

I think you'd have to manually page or click into each page, and wait for the Page Style indicator at the bottom to change?

I can half answer my question. If the page style is not in use, you can delete the style via the Manage Styles dialogue.  That then just leaves the problem of finding what pages that use the unwanted style.


(I don't know who the OP is, but it's good they won't be angry. Thanks again!)
Comment 11 Heiko Tietze 2020-05-22 14:54:43 UTC
(In reply to Luke Kendall from comment #10)
> Come to think of it, there is no way to find a page style in a document, is
> there?  You can't search for it?

Styles and Formatting sidebar has buttons on top Paragraph, Character, Frame, Page, List, Table -Style and all tabs allow to filter for used styles. With the Find & Replace dialog you can search for a page style (check Attributes...). And there is a sidebar deck for page styles so you don't need to watch the status bar.
Comment 12 Luke Kendall 2020-05-22 15:15:42 UTC
I see what you mean.

But although I see you can set the Page Style checkbox in the Attributes, you can't search for it.  There's no way to set a page style to search for, and if you leave the Find panel empty then when you search it says Search key not found.

So I don't think there really is a way to search for page styles?
Comment 13 Telesto 2020-05-22 16:33:07 UTC
(In reply to Luke Kendall from comment #12)
> (I don't know who the OP is, but it's good they won't be angry. 

Original Poster, I assume
Comment 14 Telesto 2020-05-22 16:54:32 UTC
(In reply to Luke Kendall from comment #8)
> "@Luke: Be careful with the styles and don't use DF. I would ctrl+A + Remove
> Direct Formatting, set Default CS for all text, and also clear the PS."
> 
> That's not really practical. In a 130,000 word book, working from a printed
> copy so as to re-apply all the italics alone (99.99% of changed character
> styles), that would require at minimum 3 mins work per page, so would work
> out to at minimum 23 hours of work. On top of that there would be a day or
> two of applying the 0.01% of other style information.

There are different visions.. The view that styles a superb; everybody should use paragraph/character styles. And the people should be educated about it; and see Direct Formatting as a bad habit. If the had the opportunity to get away with removing the direct formatting toolbar, the would probably do it..

And there are the - in terms of Heiko - Benjamins.. like me who still (also) use direct formatting. And seeing a UX-flaw. As the Direct Formatting (DF) toolbar is activated while using a style (without any visual feedback; between exclusively DF and formatting based on Paragraph/Character style). And overruling a Character style or Paragraph Style with Direct Formatting is not something you want.

And the visibility of the paragraph/character style formatting is an issue. But hopefully improved with https://design.blog.documentfoundation.org/2019/11/05/proposal-to-conveniently-highlight-and-inspect-styles-in-libreoffice-writer/


About the page styles in use.. 
No clue.. I can't search for it either.. And also sounds a horrible work-around, IMHO

Note: you can post also UX/UI suggestions in the bug tracker. Not 'only' broken things..