Download it now!
Bug 133259 - Find All should always report no. of matches
Summary: Find All should always report no. of matches
Status: RESOLVED DUPLICATE of bug 84583
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Statusbar Find-Search
  Show dependency treegraph
 
Reported: 2020-05-22 03:57 UTC by Luke Kendall
Modified: 2020-05-27 15:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example document to show the edge case (711.28 KB, application/vnd.oasis.opendocument.text)
2020-05-25 12:25 UTC, Luke Kendall
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke Kendall 2020-05-22 03:57:15 UTC
When you do a Find All, in all cases but one when you have at least one successful matches, at the bottom of the document window Writer reports how many matches there were, and how many characters or words matched.

This is a request to also report the number of matches in the edge case where you have one or more successful matches but the number of characters matched is zero.

This edge case happens when searching for zero-width text, such as ^$.

It means you can't know how many matches there are without some workaround like replacing the matches with some text that isn't in the document and then searching for that and then undoing the change.

Thanks for considering.
Comment 1 Dieter 2020-05-25 11:22:13 UTC
Luke, thanks for enhancement request. Could you please add a sample document, that makes the "edge case" more clear? I couldn't reproduce with a document of my own. Thanks.

=> NEEDINFO
Comment 2 Luke Kendall 2020-05-25 12:25:48 UTC
Created attachment 161261 [details]
Example document to show the edge case

Here is one.

Find all of ^$ with regex on.

(There are 172 of them I think - based on replace nbsp.s with empty strings - but you can't find that out from the UI because of the edge case.
Comment 3 QA Administrators 2020-05-26 03:36:12 UTC Comment hidden (obsolete)
Comment 4 Dieter 2020-05-26 17:30:50 UTC Comment hidden (obsolete)
Comment 5 Heiko Tietze 2020-05-27 15:55:16 UTC
dt+f3 for some dummy text, search for "he" and find 44 words selected in the statusbar. But I admit it's a workaround and we should show the number of results at least in the dialog. The hidden "search key not found" label could be a good place.

Same request has been done for the quickfind bar in bug 106383 and for the full dialog search in bug 84583. Let's make this one a duplicate of the second.

*** This bug has been marked as a duplicate of bug 84583 ***