Bug 133262 - Issues with lists in Impress (specific to Title shape)
Summary: Issues with lists in Impress (specific to Title shape)
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Impress-Bullet-Number
  Show dependency treegraph
 
Reported: 2020-05-22 06:06 UTC by Michal Svec
Modified: 2021-03-07 15:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example of a file to demonstrate broken lists (13.19 KB, application/vnd.oasis.opendocument.presentation)
2020-05-22 06:07 UTC, Michal Svec
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Svec 2020-05-22 06:06:23 UTC
Description:
Creating lists completely broken in 6.4.3, both bullet points as well as numbered. When I want to turn a bunch of lines to a list only the first one gets the bullet point and the whole paragraph is turned into a list item.

See the attached doc- trying to toggle line "D" into a bulleted point turns everything C and below into a point.

Steps to Reproduce:
-

Actual Results:
-

Expected Results:
-


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 Michal Svec 2020-05-22 06:07:24 UTC
Created attachment 161115 [details]
Example of a file to demonstrate broken lists
Comment 2 Timur 2020-05-22 12:30:06 UTC
"only the first one gets the bullet point" 
Yes, because there are no paragraph breaks in. If you copy that in Writer, all will be a single line. 
So this is NotABug. "Broken" would indicate that it worked before, but I doubt. 

OTOH, how did you create the slide? 
Not sure if there should be enhancement to convert content to list, depends on use case.
Comment 3 Michal Svec 2020-05-22 12:51:26 UTC
Hmm, that's weird. I was copying text from another ODP which looks just fine
(IIRC via "Paste as Unformatted Text") and also editing this one in place. So
probably some combination of copy/paste and editing broke it.

FTR if I paste it to Writer to goes as "C0D0E0F0G0H0I0J"
If I Paste it as Unformatted Text to Writer it shows up correctly.

Apparently the "new lines" broke somewhere along the way.
Comment 4 Aron Budea 2020-07-24 21:41:06 UTC
I've retitled the bug report, it never worked, starting with LO 3.3.0, neither in Linux or Windows.

(In reply to Michal Svec from comment #3)
> FTR if I paste it to Writer to goes as "C0D0E0F0G0H0I0J"
> If I Paste it as Unformatted Text to Writer it shows up correctly.
This however is a recent regression in Linux, until then "CDEFGHIJ" would be pasted.

Started with the following commit, bibisected using repo bibisect-linux-64-6.4:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=241bee7e4be6a205fae0d3f5508e084462c7ca55
author		Noel Grandin <noel.grandin@collabora.co.uk>	2019-10-10 11:54:27 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2019-10-10 18:50:52 +0200

convert WriteCharPtr..getStr to WriteOString
Comment 5 Aron Budea 2021-03-07 15:30:39 UTC
(In reply to Michal Svec from comment #0)
> Description:
> Creating lists completely broken in 6.4.3, both bullet points as well as
> numbered. When I want to turn a bunch of lines to a list only the first one
> gets the bullet point and the whole paragraph is turned into a list item.
> 
> See the attached doc- trying to toggle line "D" into a bulleted point turns
> everything C and below into a point.
Miklos has found the reason for this behavior recently, it's related to title shapes being used for bulleted content. Detailed explanation from the commit message:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=043690eff82d5798774452a8364e1566b866a320
"Title shapes try hard to have a single paragraph only, the Impress UI
inserts linebreaks instead of paragraphs breaks in
sd::FuText::KeyInput(), ever since commit f47a9d9db3d06927380bb79b04bb6d4721a92d2b (initial import, 2000-09-18).
This matches the PowerPoint behavior. This is most visible when the
paragraph has a bullet associated with it.

Interestingly you can still put multiple paragraphs into title shapes
using paste special -> plain text.

In that case, it was inconsistent that we exported these multiple
paragraphs to ODP, but merged them to a single paragraph on import since
commit 0a783c1a041e2b74b7bf238d11ee2c303f6708f4 (#100190# don't allow
more then one paragraph on title text objects, 2002-06-25).

This results in loosing your bullets on save + open, both in the ODP and
PPTX cases, since removeActionLock() on the XShape triggers this tweak.
Also, PowerPoint does not do this merging on import. So fix the problem
by removing the import-time tweak but leave the UI unchanged."


Since the behavior from the description hasn't changed with the fix, and isn't a bug, I'm closing this bug report accordingly.

I'll open a separate bug report for the copy/paste regression.
Comment 6 Aron Budea 2021-03-07 15:54:04 UTC
(In reply to Aron Budea from comment #4)
> (In reply to Michal Svec from comment #3)
> > FTR if I paste it to Writer to goes as "C0D0E0F0G0H0I0J"
> > If I Paste it as Unformatted Text to Writer it shows up correctly.
> This however is a recent regression in Linux, until then "CDEFGHIJ" would be
> pasted.
> 
> Started with the following commit, bibisected using repo
> bibisect-linux-64-6.4:
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=241bee7e4be6a205fae0d3f5508e084462c7ca55
> author		Noel Grandin <noel.grandin@collabora.co.uk>	2019-10-10 11:54:27 +0200
> committer	Noel Grandin <noel.grandin@collabora.co.uk>	2019-10-10 18:50:52
> +0200
> 
> convert WriteCharPtr..getStr to WriteOString
Apparently, this was fixed by the following commit in 7.1:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=516dc02998fd59035fb54f2c78b7891ac7c7578a