Download it now!
Bug 133282 - That file opens not correct in LibreOffice, but one Word version on phone it open more correct
Summary: That file opens not correct in LibreOffice, but one Word version on phone it ...
Status: RESOLVED DUPLICATE of bug 78731
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:rtf, regression
Depends on:
Blocks: FormatDetection
  Show dependency treegraph
 
Reported: 2020-05-22 17:23 UTC by vladgrom08
Modified: 2020-06-14 08:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
That file opens not correct (277.16 KB, application/rtf)
2020-05-22 17:25 UTC, vladgrom08
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vladgrom08 2020-05-22 17:23:45 UTC
Description:
That file opens not correct in LibreOffice, but one Word version on phone it open more correct 

Steps to Reproduce:
1.Just open it in LIbreOffice
2.I have last version of LibreOffice mow: 6.4.4.2
3.

Actual Results:
https://yadi.sk/i/kAxS644xscWT7w

Expected Results:
Correct opening


Reproducible: Always


User Profile Reset: No



Additional Info:
Mo
Comment 1 vladgrom08 2020-05-22 17:25:52 UTC
Created attachment 161156 [details]
That file opens not correct
Comment 2 Mike Kaganski 2020-05-22 19:02:12 UTC
This is not a DOC, this is RTF renamed to DOC. Simply renaming the extension allows to open it correctly.

However, it's unclear why is it not detected correctly, and opened as plain text. This is a regression.

Reproducible with Version: 6.4.4.2 (x64)
Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: CL

and with Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

but not with Version: 4.1.0.0.beta2
Build ID: 33224f4f11a05cfad2249e812fcc2975fbb61f6
Comment 3 Aron Budea 2020-06-14 01:16:27 UTC
I could bibisect this to three states with repo bibisect-42max. The guess between the 1st and 2nd, and the 3rd one looks promising.

1. LO crashes upon start

https://cgit.freedesktop.org/libreoffice/core/commit/?id=dd547e4a8c1895aa89e699810323c933d9ac415b
author		Stephan Bergmann <sbergman@redhat.com>	2013-07-12 18:51:26 +0200
committer	Stephan Bergmann <sbergman@redhat.com>	2013-07-12 18:51:26 +0200

"Fix headless mode glyph cache memory handling"

1 1/2. Likely where 2. actually started, based on Eike's comment in bug 67699

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d1fc3fce16172d7d619b6826de44528030ab36f8
author		Kohei Yoshida <kohei.yoshida@gmail.com>	2013-07-12 18:02:23 -0400
committer	Kohei Yoshida <kohei.yoshida@gmail.com>	2013-07-12 19:30:20 -0400

"fdo#64448: Don't get type name from incorrect filter."

2. No crash, but the file gives General input-output error.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=52bce8fadde39e32c0008babadc2c22cc501f753
author		Caolán McNamara <caolanm@redhat.com>	2013-07-16 09:12:42 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2013-07-16 12:45:56 +0100

"convert versions of dialog to .ui"

3. Raw file content displayed. (content is incomplete at this point, that's changed in a later commit)

https://cgit.freedesktop.org/libreoffice/core/commit/?id=e69aa9572bb2206313cd2aa7edd13da91460f2c4
author		Kohei Yoshida <kohei.yoshida@gmail.com>	2013-08-19 15:28:57 -0400
committer	Kohei Yoshida <kohei.yoshida@gmail.com>	2013-08-19 15:41:02 -0400

"fdo#67699: Remove a whole bunch of old hacks."
Comment 4 Maxim Monastirsky 2020-06-14 08:05:41 UTC
That file is detected as WordPerfect document, which makes it a perfect duplicate of Bug 78731. See my comment there about a potential fix.

*** This bug has been marked as a duplicate of bug 78731 ***